Skip to Content
1
Apr 25, 2020 at 06:11 AM

GRID is not showing for variant articles for generic article created using ARTMAS09 IDOC

341 Views

Hi

I have created Article through ARTMAS09 IDOC. When I create a generic article through IDOC, its creating generic (article category=01) and variants (Article category=02). And even MARA table is also showing both Generic Article and variant Articles. But when I go to display/change through MM43/MM42 transaction there System is not showing the GRID for variant articles. And it display the message "No Values have been defined a variant-creating Characteristic"

Below table explains the issue where Characteristics are stored in function module in CT04 Vs Characteristics stored directly giving values in CT04

Question is: Why GRID is displayed in case of Characteristics created and entered values in CT04

& Not displayed when the characteristics are created using the FUNCTION MODULE: WRF_CHECK_CHAR_VAL . Characteristics values are stored in this function module

SAP System: Using S4 HANA 1909 Retail. Here Class Type=300 and Class also created using the Class type=300

Error message for the generic article not displaying the GRID:

Upon clicking the variants push button, system is displaying the error message as shown in the below screen. But related variants already created in the system and MARA table also updated

MARA table view:

Upon clicking the variants push button, system is displaying the error message as shown in the below screen. But related variants already created in the system and MARA table also updated

GRID is shown in the below article for variant articles:

Upon clicking on the Variants push button system is displaying the GRID for generic article

MARA table view:

Upon clicking on the Variants push button system is displaying the GRID for generic article:

In this case GIRD displayed:

IDOC Values :

E1BPE1VARKEY:

E1BPE1AUSPRT: