Skip to Content
avatar image
Former Member

Session Inactivity Timeout

How can I set session inactivity timeout for my BSP application?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Apr 07, 2006 at 09:23 AM

    Hello Jacob,

    the time out parameters can be set for the ICM. Please check the following SAP notes: #824554, #737625 These describe wich parameters you have to influence timeout.

    Regards,

    Dezso

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Thomas Jung

      Hello Thomas,

      My ICM Timeout is set to 600 secs. The SICF BSP Application Node Timeout is set to 00:02:00. Still, no timeout is happening. Still expecting a solution.

      Regards

      Gladson

  • Apr 07, 2006 at 12:46 PM

    Hi Gladson,

    please note that the profile parameter for the session timeout is

    rdisp/plugin_auto_logout

    Regards,

    Rainer

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Rainer,

      Since you have given this info, can you also please tell me, where to assign this parameter? I mean, to which profile? Thanks in advance.

      Regards

      Gladson

      PS. I added it in the Default Profile. But I guess, the server has to be restarted, for this change to take effect. Kindly correct me, if I am wrong.

      Message was edited by: Gladson Jacob

  • Apr 07, 2006 at 03:20 PM

    Hi Gladson,

    yes, that's true. This is the parameter for all plugins

    (like HTTP).

    Have a look at

    /people/mark.finnern/blog/2003/09/24/bsp-in-depth-confusion-between-stateless-stateful-and-authentication

    there the different parameters are decribed.

    Regards,

    Rainer

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi all,

      I am having the same problem.

      These are my settings:

      rdisp/plugin_auto_logout = 600

      Timout of the SICF Service = 2 min

      From my point of view my service should now get a timeout after two minutes.

      Anyhow this setting doesn't have any effect at all.

      The timout is still 10 min.

      Am I doing anything wrong?

      Any suggestions?

      Kind regards,

      Bastian