Skip to Content
0
Jan 23, 2020 at 12:01 PM

Swagger Setup - Pegdown not found

166 Views

I'm willing to activate Swagger inside Hybris/Commerce 6.7.

For that I already:

1. created a custom extension with ywebservices.
2. enabled the webservicescommons extension into localextensions.xml

While following this link: https://help.sap.com/viewer/9d346683b0084da2938be8a285c0c27a/6.7.0.0/en-US/99783546e09949e2b4bf27795b889464.html I already:

1. visited https://localhost:9002/my-custom-extension-from-ywebservices/swagger-ui.html and verified that the page is being loaded.
2. executed 'ant wsStaticDoc'

When doing this, I get the following error:

[main] ERROR org.apache.maven.cli.MavenCli - Failed to execute goal io.github.swagger2markup:swagger2markup-maven-plugin:1.2.0:convertSwagger2markup (default-cli) on project swagger-documentation: Execution default-cli of goal io.github.swagger2markup:swagger2markup-maven-plugin:1.2.0:convertSwagger2markup failed: A required class was missing while executing io.github.swagger2markup:swagger2markup-maven-plugin:1.2.0:convertSwagger2markup: org/pegdown/PegDownProcessor

As this is a dependency error, I tried to:

1. put the pegdown dependency into my ywebservices custom extension external-dependencies.xml file
2. enable maven
3. execute ant mavenUpdateDependencies

I also tried to force things up by placing the same dependency into the webservicescommons extension external-dependencies.xml file.

Nothing worked.
Does anyone have a clue?