Skip to Content

#ABAP_trial NW7.52SP04 Installation problem

Hello

I'm trying to install NW7.52SP04 in a VirtualBox machine. My installation ends up with the following error:

=>sapparam(1c): No Profile used.
=>sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline
################################################
Abort execution because of 
Step returns modlib.jslib.caughtException
################################################


Error code: 20
++++ Support data section BEGIN ++++
* mount
Error: sapinst has finished with an error code, please find logs in /tmp/sapinst_instdir

At first I thought this was because of password which contained special characters, but I changed password for my user (capital, small letters and digits, no special chars), for 'root' and deleted users created by the installation process. Restarted instalaltion twice already, but it end up with the error every time.

Please help!

More context from the log:

[OK] SAPHostExec / SAPHostControl succesfully installed
Executing: "/usr/sap/hostctrl/exe/SAPCAR" -xvf "./SHADBMETRICSDEF.SAR" -R "/usr/sap/hostctrl/exe/config.d" 
SAPCAR: processing archive ./SHADBMETRICSDEF.SAR (version 2.01)
x dbmetric.definition.db4.cimobj
x dbmetric.definition.db6.cimobj
x dbmetric.definition.hdb.cimobj
x dbmetric.definition.mss.cimobj
x dbmetric.definition.ora.cimobj
x dbmetric.definition.sap.cimobj
x dbmetric.definition.siq.cimobj
x dbmetric.definition.syb.cimobj
x dbmetric.definition.tst.cimobj
x dbmetrics.d
x dbmetrics.d/00.general.hdb.cimobj
x dbmetrics.d/00.state.hdb.cimobj
x dbmetrics.d/10.host.capacity.hdb.cimobj
x dbmetrics.d/20.indexserver.hdb.cimobj
x dbmetrics.d/20.nameserver.hdb.cimobj
SAPCAR: 15 file(s) extracted
SAPCAR: rc 0 
=>sapparam(1c): No Profile used.
=>sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline
################################################
Abort execution because of 
Step returns modlib.jslib.caughtException
################################################


Error code: 20
++++ Support data section BEGIN ++++
* mount
Error: sapinst has finished with an error code, please find logs in /tmp/sapinst_instdir
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
devtmpfs on /dev type devtmpfs (rw,nosuid,size=4073212k,nr_inodes=1018303,mode=755)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
/dev/sda2 on / type ext4 (rw,relatime,data=ordered)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=23,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=12922)
mqueue on /dev/mqueue type mqueue (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=816216k,mode=700,uid=1000,gid=100)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
/dev/sr0 on /run/media/grzegorz/openSUSE-Leap-15.1-DVD-x86_64470 type iso9660 (ro,nosuid,nodev,relatime,uid=1000,gid=100,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks2)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
* df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        3.9G     0  3.9G   0% /dev
tmpfs           3.9G  8.0K  3.9G   1% /dev/shm
tmpfs           3.9G  9.3M  3.9G   1% /run
tmpfs           3.9G     0  3.9G   0% /sys/fs/cgroup
/dev/sda2        96G   54G   38G  59% /
tmpfs           798M  4.6M  793M   1% /run/user/1000
/dev/sr0        3.8G  3.8G     0 100% /run/media/grzegorz/openSUSE-Leap-15.1-DVD-x86_64470
* df -hi
Filesystem     Inodes IUsed IFree IUse% Mounted on
devtmpfs         995K   449  994K    1% /dev
tmpfs            997K     3  997K    1% /dev/shm
tmpfs            997K   644  996K    1% /run
tmpfs            997K    18  997K    1% /sys/fs/cgroup
/dev/sda2        6.2M  194K  6.0M    4% /
tmpfs            997K    39  997K    1% /run/user/1000
/dev/sr0            0     0     0     - /run/media/grzegorz/openSUSE-Leap-15.1-DVD-x86_64470
* cat /etc/os-release
NAME="openSUSE Leap"
VERSION="15.1"
ID="opensuse-leap"
ID_LIKE="suse opensuse"
VERSION_ID="15.1"
PRETTY_NAME="openSUSE Leap 15.1"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:15.1"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
* ls -ld / /sybase /usr/sap /sapmnt
drwxr-xr-x 24 root root   4096 Jan 16 14:38 /
drwxr-xr-x  3 root root   4096 Sep  6 12:30 /sapmnt
drwxr-x---  2 1002 sapsys 4096 Jan 16 15:21 /sybase
drwxr-xr-x  7 root root   4096 Jan 16 14:46 /usr/sap
++++ Support data section END ++++
All logs have been written to the file /home/grzegorz/abaptrial/ABAP/install_2020-01-16_15-22-13.log
Please see readme.html to find out how to get help


Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

8 Answers

  • Best Answer
    Posted on Feb 10 at 01:51 PM

    For the ones who'll be seeking for help and information in the future. I managed to resolve it! The guideline document does not provide the key information to update /etc/hosts in the proper way to have a successfull install on OpenSUSE Leap 15 with a NAT setup.

    Instead of:

    10.0.2.15   vhcalnplci

    you should set it exactly to:

    10.0.2.15 vhcalnplci.dummy.nodomain vhcalnplci

    This simple thing solved my problem!!! :-) I've found this in another thread from 2017. The interesting thing is that this is mentioned in the installation FAQ but only for the cases where people want to change back to NAT (the default config from the installation guideline). But the installation guideline itself doesn't mention this.

    @Frederic Girod - thank you for all your support. You were right that this could be domain related. The difficulty here was to find the proper solution for this error which I gave above.

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 17 at 03:49 PM

    sapinstlog.txtsapinst-devlog.txt

    Did you mean log files from /tmp/sapinst_instdir/NW73/SBC/STANDARD/? I attached them both, but can't see anymore information in there.


    sapinstlog.txt (36.8 kB)
    sapinst-devlog.txt (920.1 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 21 at 06:23 AM

    You have several issues in your install. But I think, if you want to simplify the install, instead of OpenSuse, try SLE (SUSE Linux Entreprise) Server for SAP Hana.

    I am not sure also you have configure the file /etc/hosts to set the Hostname --> Ip address

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 21 at 03:14 PM

    Thanks for coming back. Yeah, I did set the host name and IP mapping. There was only 1 step I did wrong in the install at the beginning - password wasn't compliant. After the first failure I saw this and changed passwords. Tried to reinstall but it didn't improve anything.

    I must say when I first did such NW trial install 3 years ago - it was an easy and smooth process. Did it 3 times and never experienced a single issue. But now with the new NW I was not able to have at least 1 successfull install. If my old virtual machine with NT 7.50 still worked that would be great, but due to licence expiration it doesn't even start SAP :(

    The new guideline for 7.52SP04 on OpenSUSE Leap has errors in it. Steps order are wrong, the content is also wrong (screenshots showing other things than in the text), missing steps (e.g. enable SSH port forwarding before copying files)...I only knew how to proceeed because I did it in the past. Not sure if the publisher went through the guideline before publishing it.

    I don't know how to move forward...starting from scratch didn't solve my problem.

    Add comment
    10|10000 characters needed characters exceeded

    • Yeah, I noticed this, but since it's just a warning I ignored it. Perhaps that's the problem, but the person with the solution uses Ubuntu and I use OpenSUSE Leap as per the guideline. Also the guy runs with a bridged setup and I setup NAT as per the guideline. The other commenter to that post changed his VM config to NAT from bridge and it helped him. I have the NAT config from the very beginning and still no luck.

      I'll try to assign a static IP and see.

      What is your setup? Bridge or NAT? What happens when you ping your domain?

      Thanks for all the help so far.

  • Posted on Jan 23 at 01:23 PM

    Does anyone have any idea? Julie Plummer perhaps?

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 03 at 04:23 PM

    Today I tried again. I followed a video guideline this time. However still can't get this thing installed successfully :(

    Today I got the following errors:

    WARNING 2020-02-03 09:14:02.679 (root/sapinst) id=modlib.jslib.childAppReturn
    Execution of the command "/sybase/NPL/OCS-16_0/bin/isql64 -w999 -USAPSR3 -Svhcalnplci:4901 -X" finished with return code 255. Output: 
    Password: 
    Msg 10513, Level 16, State 1:
    Server 'NPL':
    Temporary database based on specified binding could not be assigned. Since binding is hard, this results in a login failure.
    Msg 4002, Level 14, State 1:
    Server 'NPL':
    Login failed.
    CT-LIBRARY error:
    	ct_connect(): protocol specific layer: external error: The attempt to connect to the server failed.
    
    
    ERROR 2020-02-03 09:14:02.682 (root/sapinst) id=ind-rel.ind-os.ind-db.assertionFailed errno=CJS-00030
    Assertion failed: Unable to verify database access for login SAPSR3. Refer to trace file sapinst_dev.log for further information.
    
    
    ERROR 2020-02-03 09:14:02.683 (root/sapinst) id=modlib.jslib.caughtException errno=MUT-03025
    Caught ESAPinstException in module call: Assertion failed: Unable to verify database access for login SAPSR3. Refer to trace file sapinst_dev.log for further information..
    
    
    ERROR 2020-02-03 09:14:02.945 (root/sapinst) id=controller.stepExecuted errno=FCO-00011
    The step syb_step_login_check with step key |offlineadjustment_dialogs|ind|ind|ind|ind|0|0|offlineadjustment_db_post|ind|ind|ind|ind|db_post|0|syb_rename_db_post_dia|ind|ind|ind|ind|syb|0|NW_SYB_DB_REN|ind|ind|ind|ind|syb2|0|syb_step_login_check was executed with status ERROR (Last error reported by the step: Assertion failed: Unable to verify database access for login SAPSR3. Refer to trace file sapinst_dev.log for further information).
    
    
    INFO 2020-02-03 09:14:05.495 (root/sapinst)
    Creating file /tmp/sapinst_instdir/NW73/SBC/STANDARD/INSTANA.XML.
    
    
    INFO 2020-02-03 09:14:05.994 (root/sapinst)
    Creating file /tmp/sapinst_instdir/NW73/SBC/STANDARD/instslana.xml.
    

    And more details from sapinst_dev.log:

    TRACE      2020-02-03 09:14:02.677 (root/sapinst) (startInstallation) [syuxctask.cpp:465] CUnixProcessManager::sap_waitpid()
    Child process 6564 returned 255
    
    
    
    
    WARNING    2020-02-03 09:14:02.679 (root/sapinst) (startInstallation) [iaxxbjsmod.cpp:83] id=modlib.jslib.childAppReturn
    Execution of the command "/sybase/NPL/OCS-16_0/bin/isql64 -w999 -USAPSR3 -Svhcalnplci:4901 -X" finished with return code 255. Output: 
    Password: 
    Msg 10513, Level 16, State 1:
    Server 'NPL':
    Temporary database based on specified binding could not be assigned. Since binding is hard, this results in a login failure.
    Msg 4002, Level 14, State 1:
    Server 'NPL':
    Login failed.
    CT-LIBRARY error:
    	ct_connect(): protocol specific layer: external error: The attempt to connect to the server failed.
    
    
    TRACE      2020-02-03 09:14:02.680 (root/sapinst) (startInstallation)
    syb_runAs: set current directory to /tmp/sapinst_instdir/NW73/SBC/STANDARD
    
    
    TRACE      2020-02-03 09:14:02.681 (root/sapinst) (startInstallation) [syuxccuren.cpp:541] CSyCurrentProcessEnvironmentImpl::setWorkingDirectory(const CSyPath& /tmp/sapinst_instdir/NW73/SBC/STANDARD)
    Working directory changed to /tmp/sapinst_instdir/NW73/SBC/STANDARD
    
    
    TRACE      2020-02-03 09:14:02.681 (root/sapinst) (startInstallation)
    syb_isql: do not return isql output because of exit code 255
    
    
    TRACE      2020-02-03 09:14:02.681 (root/sapinst) (startInstallation)
    syb_login_possible: login as SAPSR3 failed
    
    
    TRACE      2020-02-03 09:14:02.681 (root/sapinst) (startInstallation)
    syb_step_login_check: unable to login with db user SAPSR3
    
    
    TRACE      2020-02-03 09:14:02.682 (root/sapinst) (startInstallation)
    syb_step_login_check: user decided to stop
    
    
    ERROR      2020-02-03 09:14:02.682 (root/sapinst) (startInstallation) [CInstallerCallBackImpl.cpp:259] id=ind-rel.ind-os.ind-db.assertionFailed errno=CJS-00030 CInstallerCallBackImpl::abortInstallation()
    Assertion failed: Unable to verify database access for login SAPSR3. Refer to trace file sapinst_dev.log for further information.
    
    
    
    

    These are the whole log files for reference:

    https://drive.google.com/file/d/134vwIKCD-pYi-y-3W2Px4GAHXtGtI_uy/view?usp=sharing
    https://drive.google.com/file/d/1OqK69uHH9_sIGzWJwgv8NaUccfKbtBix/view?usp=sharing

    Julie Plummer please help!

    Add comment
    10|10000 characters needed characters exceeded

    • Several things.

      • Host found in your log
      Found these instances: 
      sid: NPL, number: 00, name: D00, host: vhcalnplci, Service definition file /usr/sap/sapservices
      sid: NPL, number: 01, name: ASCS01, host: vhcalnplci, Service definition file /usr/sap/sapservices
      sid: NPL, number: 01, name: ASCS01, host: vhcalnplcs, Profile directory /usr/sap/NPL/SYS/profile
      

      So, you have configured vhcalnplci in the /etc/hosts but not the chcalnplcs. Did you try several install in the same system, trying to change the host ? If yes, delete everything & restart. If no, add the missing name in the /etc/hosts file.

      To test your /etc/hosts file, just do a "ping {hostname}"

      • when you will restart your install, check this line is not present anymore
      INFO 2020-01-16 15:25:18.232 (root/sapinst)
      Problem with the DNS configuration: could not determine the DNS domain of host vhcalnplci
      
      • Again, SLE is a better option
      WARNING 2020-01-16 15:25:24.854 (root/sapinst)
      Running an installation on this distribution of Linux is not supported by SAP in any way!
      
      • You need to fixe this also
      WARNING 2020-01-16 15:25:36.723 (root/sapinst) id=syslib.network.getInfoFailed
      Unable to determine parameter "DNS domain name". DNS domain name is not configured in resolv.conf (UNIX) or the registry (Windows) and neither getaddrinfo nor gethostbyname could retrieve it.
      

      I don't know this distribution, maybe check the wiki (https://en.opensuse.org/SDB:Configure_DNS)

      • I don't remember exactly, but I think you need several packages to run the install, like GCC, linux-header, ...
      WARNING 2020-01-16 15:26:25.729 (root/sapinst) id=modlib.jslib.childAppReturn
      Execution of the command "/bin/rpm -q gcc" finished with return code 1. Output: 
      package gcc is not installed
      

      (apparently you need CSH, LIBAIO, UUIDD, ...)

      There is this blog, could help you in the install : https://blogs.sap.com/2019/04/01/part-1-installing-sap-netweaver-as-abap-developer-edition-7.52-sp01-on-virtualbox-ubuntu-16.04/#section56

      it recommends to run this install command

       sudo apt-get install gcc perl csh libaio1 libc6 libstdc++6

      So, again, try to correct as much as possible the problems.

      If you try to install several time on the same system, do not change the hostname, the database name, ... You are using a virtualbox, you certainly could save the System install & backup it.

      when you have correct the warning/error, resart the install, check the log file for Error Warning again.

      good luck

      Fred

  • Posted on Feb 07 at 06:24 AM

    Hi Grzegorz

    i have just installed this version. please check these items below:

    1. if you installed many times, please delete /sapmnt and /sybase folder. you do not need to install the OS again and again. btw, you can add a snapshot instead.

    2. by any means, please set the ip address such as 10.0.2.4 static manually. I cannot set it in PaTY so use network master instead. the network mask is 255.255.255.0, gateway should be 10.0.2.2

    3. add an extra line in your /etc/hosts

    <route ip, normally 10.0.2.2> dummy.nodomain

    so that when you ping dummy.nodomain, you will get your route ip. (not your host ip)

    good luck.

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on 6 days ago

    Hi Grzegorz,

    Is your question answered (from Comments https://blogs.sap.com/2019/07/01/as-abap-752-sp04-developer-edition-to-download/comment-page-1/#comment-493708):

    "Only this one below helped.

    For NAT network configuration the /etc/hosts file should contain this entry:

    10.0.2.15 vhcalnplci.dummy.nodomain vhcalnplci "

    If not, please let me know.

    Best wishes, Julie.

    Add comment
    10|10000 characters needed characters exceeded