Skip to Content
avatar image
Former Member

Problem with delta activation in R3

Hi experts,

I have a problem with my 5.0 initial download. I only made the DNL_CUST_* objects but there are BUPA_MAIN BDOCs in my CRM system (I checked that CRM deltas are inactive, R3AC4 tcode). Doing some tests I could see that these BDOCs are the correspondant to delta modification of R3 customers. I asked to client system administrators and I discover that actual R3 backend was used in other project with another CRM system so, ┬┐it's possible that R3 has these delta in a active status in order to previous initial?

If yes, has anyone know how could I deactive these deltas? Maybe some R3 table?

I promise reward your answers, it's very important for me.

Thanks in advance

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 06, 2006 at 11:51 AM

    Hi

    On the R/3 side, you have to create an RFC Destination to the CRM system. Then activate CRM as

    consumer in table CRMCONSUM and maintain the table CRMRFCPAR. Through this table, the

    determination of the RFC destinations for the data transfer is connected with the consumer, client,

    object name and transfer type. For example, you can send data to a consumer in an initial download

    only, and not in a delta download.

    > In the CRM system, you have to create an RFC Destination to the R/3 backend and a R/3 Site with the

    tool Administration Console. The R/3 Site references the RFC-Destination. Activate R/3 OLTP as

    consumer in table CRMSONSUM.

    Hope it helps

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 06, 2006 at 11:57 AM

    Try removing all entries from the PIDE transaction.

    You can also set the filter in object customer_main of CRM to exclude everything.

    & There's a customizing entry somewhere to deactivate the queues, but can't remember where.

    Michael.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Michael,

      Thank you very much for your help but i'd need more help. I tried to deactivate de delta's in table CRMSUBTAB by setting the Inactive checkbox as flagged, but the customers, sales documents.... are still downloading. Can you be more specific in terms of these table's modification please? Can I delete table registers?

      For example...

      CRM BUAG_MAIN Download BUPA

      CRM BUAG_MAIN Upload BUPA

      CRM BUPA_MAIN Download BUPA

      CRM BUPA_MAIN Upload BUPA

      CRM BUPA_MAIN_20C Download BUPA

      CRM BUPA_REL Download BUPA

      CRM BUPA_REL Upload BUPA

      CRM BUPA_REL_20C Download BUPA

      Other test is set the "Stop Data" checkbox in CRMRFCPAR table as flagged. The BDOC's are now not generated but I don't know the implications of this modification.

      Please shed me some light on this.

      Thanks in advance

      Message was edited by: Fernando Javier Merino Vivar

  • avatar image
    Former Member
    Apr 07, 2006 at 09:10 AM

    Try entering object "customer_main" and inactivate upload & download.

    Michael.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you Michael but I alredy did this test and it worked. I write an OSS message in order to request the SAP connection services. If I found the correct solution I'll post it here for your knowledge.

      Kind regards

  • avatar image
    Former Member
    Sep 07, 2006 at 08:17 AM

    Hello there,

    we are experiencing a bit of a problem.

    Currently in the midst of an implementation, we are setting up SAP IS-u and CRM 4.0.The Business Agreeement somehow does not replicate to the CRM system, any suggestions?

    Kind Regards

    Add comment
    10|10000 characters needed characters exceeded