Skip to Content
1
Jan 12, 2020 at 09:05 PM

Cloud MTA build tool fails permanently

611 Views Last edit May 21, 2020 at 02:57 PM 2 rev

Just a moments ago tried to build my MTA project and currently the build fails with the following error:

20:48:11 (Executor) Running "openui5_preload:preloadTmp" (openui5_preload) task
20:48:12 (Executor) Warning: Cannot read property 'length' of undefined´┐Ż Use --force to continue.
20:48:12 (Executor)
20:48:12 (Executor) Aborted due to warnings.
20:48:12 (Executor) [2020-01-12 20:48:12] ERROR could not build the "XXXXXXXX" module: could not execute the "grunt" command: exit status 3

The error is caused by UI5 module, node js modules of this MTA do not produce errors

Gruntfile.js has not been changed for more than a month. ESLint does not indicate any errors. Also tried to return to older version of the project with the same result.

The Gruntfile.js looks as follows

module.exports = function (grunt) {
	"use strict";
	grunt.loadNpmTasks("@sap/grunt-sapui5-bestpractice-build");
	grunt.config.merge({
		compatVersion: "edge"
	});

	grunt.registerTask("default", [
		"clean",
		"lint",
		"build"
	]);
	
	grunt.loadNpmTasks("@sap/grunt-sapui5-bestpractice-test");
	grunt.registerTask("unit_and_integration_tests", ["test"]);
	grunt.config.merge({
		coverage_threshold: {
			statements: 0,
			branches: 100,
			functions: 0,
			lines: 0
		}
	});
};