Skip to Content
0

Using comma instead of dot in csv file SAP HANA

Feb 14, 2017 at 02:35 PM

81

avatar image
Former Member

Hello,

I have a config file which is going through an SDI agent, I have created a flowgraph to load the csv file into target table.

The client while uploading the csv file is using comma instead of dot for decimals.

When I use comma in the csv file, the data is rounded i.e. 33,33 --> 3333
The result should display : 33,33 --> 33,33

What configuration should I do to get the correct answer?

Thank you,

Shehzad

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Timo Wagner
Mar 03, 2017 at 06:56 PM
1

Hello Shehzad,

you can configure this through the locale config parameter.

If you take a locale that usually uses a comma to as a decimal pointer it should recognize 33,33 as such and not as 3333. For your case the German locale (de_DE) might work.

Further down in this blogpost (https://blogs.sap.com/2016/01/06/hana-smart-data-integration-the-file-adapter/) You can find more details about the individual config parameters.

Kind Regards,

Timo Wagner

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello,

Sorry for late reply.
Its the perfect solution to the problem.

Thank you very much.

Shehzad

0