Skip to Content

Error when deploying PDFManipulation and XMLForm

Hi.

I'm installing the adobe services and SDM returns errors when deploying the pdfmanipulation and xmlform sca's:

Caused by: com.sap.nwmss.jdbc.base.BaseBatchUpdateException: [NWMss][SQLServer JDBC Driver]Communication error: The stream provided does not contain the number of bytes specified. For batches, please ensure that streams are reset before subsequent addBatch calls. This is a non-recoverable error and the connection has been terminated.

Platform: WebAS 6.40 SP16 on Win2003 and MSSQLServer 2000

Any idea's? Can't find anything in SAPNotes

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 07, 2006 at 09:50 AM

    Hi,

    We had a similar problem today. The ADS installation ended with the following error:

    Caused by: <i>com.sap.nwmss.jdc.base.BaseBatchUpdateException: [NwMss] [SQLServer JDBC Driver] The DBMS returned an unpsecified error. The command code was 0.</i>

    It turned out to be a memory allocation problem of our SQL server. We had to set the preallocated memory area for SQl Server from the default 256M to 512M according to not #795991 (https://websmp209.sap-ag.de/~form/sapnet?_FRAME=CONTAINER&_OBJECT=012006153200001640032004). After setting this parameter, the installation of ADS continued successfully.

    Hope this helps.

    Cheers!

    Frodo

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Frodo,

      you the man! 10 points for you. It solved the problem.

      It's really frustrating that I tried so hard to find a note with the error text via SDN and SAPnotes search without succes, and this note contains the EXACT error message. Time for SAP to integrate Google!

      2 points for Mike for moral support!

      Cheers

      Marcel

  • avatar image
    Former Member
    Apr 06, 2006 at 11:55 AM

    Hi, I'm working on the same thing at the moment, having the same problem.

    I checked if the DB has enough space and so on, but I didn't found any solution.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member M. Rabe

      I read something about an problem, if your packet size is higher than 8090, you will also get some errors concerning the memory allocation. No idea if this has something to do with the problem, but...

      I will try this now....

      Message was edited by: Michael Brunner

  • avatar image
    Former Member
    Aug 16, 2006 at 04:40 PM

    I am also receiving the same errors as this message described, however I have check the parameters and all are set according to the notes and ideas mentioned. Does anyone have any other ideas which can be checked?

    Add comment
    10|10000 characters needed characters exceeded