Skip to Content

Crystal Report dont show in Visual Studio 2019 extensions and VS behaviour not normal

Hi,

I have problems with Crystal Report for Visual Studio 2019 and looking forward for any help. Before i describe the problems, here is my app n win description:

  • Windows 10 Pro N, version 1803, OS Build 17134.1069. 64 bit
  • VS Community 2019. V 16.3.7
  • .NET framework 4.8.03761

1. I have added CR developer for VS 2019, and download ( CRforVS13SP25_0-10010309.exe - rar executable) as normally, and then install it as administrator. And also the run time engine for .NET Framework right after that. But (after reboot) CR for VS extension don't show in installed extensions and still showing available to download in online search ( you can see in red box at picture). But some how CR tool are exist normally in toolbox, as you can see that i can add CR viewer to the Form1.vb ( you can see in yellow box at picture). I thought that it's still ok as long as i can use CR normally. But after that the VS 2019 behaviour is not normal (window focus changed randomly, if i click reportviewer properties will somehow hang and so on). Is this because CR is not show normally in extension?

2. I have searched for the problem and i allready tried solutions below :

  • Install the CR for VS (as admin, and reboot)
  • Repair VS 2019 installation (reboot)
  • I also tried to reset win10 with remove everything option and repeat the VS and CR installation

But the result still the same. Did i missed a step or something?

3. When i add CR viewer to Form1.vb, and the reference is loaded normally and i figured all the reference path that related to CR is point to -->

"C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86" (you can see in green box and blue circle at picture) as i thought that "win32_x86" is usually means for 32 bit windows. FYI, there is also a folder with same directory but named "win64_x64". Is this normal? or maybe this is related to the problem no. 1 above?

Below is the screen shot

Thank you

preview1.jpg (294.7 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Nov 04, 2019 at 02:19 PM
    -1

    This is a known problem with VS2019 and Cr4VS sp25

    sp26 is expected to solve the problem, but it's not yet out.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.