Skip to Content

Change Number not copied to BoM from ECTR

Hi Team,

When I create an assembly in Solidworks and import the files to SAP with a Change number, the DIR's are created accordingly. I then create materials and then when I select "Derive Bill of Material 2(Single level), it creates the BoM, but the Change number is not copied from the DIR's.

When the did this same process in ECTR 5.1, it works flawlessly, but not in S4ECTR 1.1. The settings in Default.txt is set to True to copy the Change number from DIR.

I also read that I will need to setup api definitions, but I only see BoM display and Change there. Is an addition in that file required? Any other config corrections required?

Thanks,

Prashanth

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Nov 08, 2019 at 08:56 AM

    Hello Prashanth,

    please check your <ECTR inst dir>\basis\aux-files\api_definitions2.xml

    Please check the section containing:

    <!-- CDESK_SRV_MBOM_WIZARD Single-Level DOCUMENT-->
     <function apiname="CDESK_SRV_MBOM_WIZARD" name="CDESK_SRV_MBOM_WIZARD_SINGLE_DOC" ...
    

    Parameter getecm="document" uses the DIR's change number, getecm="active" the active change number.

    Hope this helps.

    Regards,

    Gerhard


    use-active-ecn.png (47.7 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 08, 2019 at 01:40 PM

    Hello Gerhard,

    Thanks for the response. I have checked this and it states "document".

    When I try to create the BoM, the field Change number is not showing up in BoM Preview. I have compared the configuration between ECTR 5.1 and S4 1.1 and found no changes.

    Is this related to a note?

    Thanks,

    Prashanth

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.