Skip to Content

SAP PO 7.5: transport / deployment of iFlows

Dear experts,

I create an iFlow in DEV, activate and deploy it. Now when I transport the iFlow using CTS+ to our TEST/QA system do I have to deploy it manually again?

Thank you, Peter

Add a comment
10|10000 characters needed characters exceeded

  • I saw that sometimes the generated ICO is missing when I open an iFlow in the Integration Builder. I go back into NWDS, deploy the iFlow, go back into Integration Builder and then can see the generated ICO attached to the iFlow. Is that the proper "workflow"?

Related questions

1 Answer

  • Best Answer
    Posted on Oct 31, 2019 at 08:04 PM

    Hi Peter,
    When you create the IFlow in NWDS, you have to activate and deploy the iflow in NWDS.

    Once the iFlow is deployed, you will see the ICO is attached to the iFlow.

    It is very important when you transport to higher env. you should only include the iFlow in your CTS+. And then once transport is successful you have to deploy the iFlow in higher env. using NWDS- this will create the ICO. If you select both iFlow and ICO to transport , it will fail when you will try to activate and deploy the iflow.

    Thanks

    Sugata

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.