Skip to Content

SAP Business One Service App Processing Failed Attachments folder not defined

Dear Experts,

SAP Business One Service App show messages:

Processing Failed

Attachments folder not defined, or Attachments folder has been changed or removed

during uploading picture via Mobile Network 4G, for service call:

Error message:

But Our Path is defined for Company:

What can cause this problem ?

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on Oct 30, 2019 at 08:34 AM

    Hi Aleksandar, in earlier versions there was some issue in Cloud context, but cleared since PL07. So not sure what's your SAP Business One version. Was that ever working before, or does it work under different network (as you outline 4G)? Have you reviewed documentation in
    https://help.sap.com/viewer/90b48bbecf6040ccaa82000f01da3a9c/1.0/en-US/ad8724e5da504639a1302343ea6a9e68.html ?

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Peter,

      our version is SAP Business One 9.3 PL06, and it's not on Cloud.

      No it's not working before.

      I must apologize for my delayed response, I was very busy with another things.

      I have reviewed documentation, but I got new error:

      I will describe what I have done:

      We can only use Linux for attachments in our case.

      - Create folder in /hana/data/attch1

      - Create folder in /hana/data/attch2

      - command:
      chmod 777 -R /hana/data/attch1

      - command:
      chmod 777 -R /hana/data/attch2

      - Share folder on this way:

      - command:
      mount -t cifs -o user=b1service0,pass=b1service0,sec=ntlmssp,uid=ndbadm,forceuid '//192.168.65.12/attch1' /hana/data/attch2


      And I can see this folder from windows machine, and there is file 'tk.png' from mobile application (see first image) which I tried to attach, but their size is 0 KB:

      Do you know what's the problem here?

  • Posted on Nov 28, 2019 at 03:17 AM

    Hi Aleksandar,

    This is Yi Feng from the B1 Mobile engineering team. I read through your issue described above.

    The online help for attachment folders set-up is documented at https://help.sap.com/viewer/90b48bbecf6040ccaa82000f01da3a9c/1.0/en-US/ad8724e5da504639a1302343ea6a9e68.html.

    It is for B1 attachments syn-up between Linux server (the hana server) and Windows server (B1 client) so that the data integrity can be maintained for the attachments from either mobile side or B1 client side.

    After reading your issue description above, it seemed that you created two folders - attch1 and attch2 on the hana server and tried to syn up them. We don't have the practice. Please follow the online help to create attachments folders on both Windows and Linux servers respectively, then mount them together.

    If there is still a problem with attaching files in the mobile app, you can raise a customer incident to us, we're glad to look into it.

    Thanks,

    Yi Feng

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Yi Feng...
      I see You are from the team SAP B1 mobile. I would like to ask You. I am using on Android SAP Business One.
      I am facing the problem open an PDF attachment from the App.
      When I want to open the PDF(for exapmle attachment in Sales Order) it says 'processing failed'. To I can view the attachment from the SAP Business One(Android), what I need set?
      a) Is neccessary mount the windows folder(Attachments) into Linux same as for SBO(HANA)mailer?
      b) Or just set WIndows SMB permissions
      c) any folder setting is not need and the attachment is send from the mobile App via HTTP?
      The work with attachments it self on desktop version of SAP Business One works properly, just on the Android is the problem.

      Thank You
      Regards Zdenek

  • Posted on Dec 04, 2019 at 04:25 PM

    Hello Yi Feng,

    I found some solution based on your answer

    Setting Up Attachment Folder

    under section "On-Demand Environment", but I must modify instruction steps to resolve my issue.

    And I was investigating a little bit more:

    - Create folder in /hana/attch1

    - Create folder in /hana/attch2

    - Share folder and mount it, to resolve "Access is denied" error, provide correct username and password, in my case b1service0 has not password set.

    I refer to my first post that I don't have to write all over again, and this mount command resolved my problem:

    mount -t cifs -o user=b1service0 '//192.168.40.10/attch1' /hana/attch2

    but if you have password you should use this one:

    mount -t cifs -o user=b1service0,pass=**password** '//192.168.40.10/attch1' /hana/attch2

    - All mounts on Linux:

    - SAP B1 Path Settings:

    - SAP Business One Service App:

    - Next:

    - Next:

    - I can see this new image:

    But, If I change my attachments folder in SAP B1 Path settings from

    \\192.168.40.10\attach1

    to

    \\192.168.40.10\attch1\AERION_GT_TEST1\Attachment\

    - Then I get problem (maybe this is some issue in SAP Business One Service App):

    - Next:

    - And if I try to download existing photo, which still exist on Network, then I get this:

    Maybe you should review this issue with development team.


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.