Skip to Content

Client Delete Does Not Work In Background

I have a very strange issue.

Attempting to delete a client via SCC5 in the background does not work. It DOES work via the foreground.

Let me clarify what "does not work" means. When I run SCC5 (logged in to the client I want to delete as an administrative user with SAP_ALL) it proceeds normally all the way through. It asks the usual questions, and upon choosing run in background, I get the usual final confirmation screen "use SCC3 to monitor". So it appears as though everything is fine. However, SCC3 never shows anything (not processing, not cancelled, not anything). Going to SM37 to check the job, I find the job in FINISHED state (it somehow thinks it was successful), but the runtime is either 0 seconds or 1 second. And of course, the client is still there and fully functioning.

Environment

S/4HANA 1809 FP00. App Server is Windows. DB Server is SLES. Pretty vanilla setup, no additional components installed beyond the ISS. Kernel is 773 PL 200.

Further Notes

1) I initially discovered this in a Sandbox system I had refreshed (system copy) from QAS. After beating on the issue with no success for quite a while, I simply re-did the refresh with a new backup set, in hopes something or another happened with the original source backup. No joy.

2) After that, I went to the SOURCE system (QAS) and created a new client via client copy from one of my other clients. I then tried to delete it, and experienced the exact same thing. So whatever it is, is not related to the system copy.

3) I have rebooted both the APP and DB server, just to get that out of the way.

4) I have available BTC work processes. The system is sized nicely, with plenty of available resources in all categories (Mem, Proc, Disk). SM50 shows little to no activity when I attempted this.

5) Batch jobs ARE running successfully in both the source QAS system and the refreshed sandbox system. Standard jobs, no problem, and as I mentioned above I can successfully schedule client COPIES and have them run just fine.

6) There are no apparent errors logged, in anywhere I have looked. The SM37 job log for the client delete does not have anything useful in it, as it thinks it was successful. SM21 system log is clean. No dumps in ST22.

7) There are no other issues going on with this system or the source system. Everything seems to be working and performing fine from a Basis perspective.

8) Update is active with no failed updates. RZ04 has a defined instance, though we are not using op modes. Out of desperation I created a Job Group server (the DEFAULT_BTC one) in SM61, which went fine but didn't help my problem.

This issue is difficult to fit into a search criteria, since there are no "failures" per-se, no errors, and any attempt at looking up "SCC5" "RXCLCOP" or any other term just results in thousands of unrelated hits.

Thoughts?

Edit: Since it is able to delete successfully via foreground, and I have no other issues, you may be wondering why I am going to such lengths to figure this out. That's just me. I have learned with SAP that these mystery problems have a way of surfacing later in more critical moments.

Add a comment
10|10000 characters needed characters exceeded

  • As an additional comment, I have tried this on a different customer, who also runs 1809 FP00. This exact same behavior is present there. So at this point I believe it is not specific to my systems. I have opened an SAP incident and will see what they say.

Related questions

2 Answers

  • Best Answer
    Posted on Oct 29, 2019 at 10:29 PM

    This issue is addressed by SAPNote 2710525.

    For some reason, it never came up in any of my exhaustive searches, either on SAP sites or external sites.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 26, 2019 at 12:19 AM

    Hi Steve,

    Did you select option " Delete client entry from T000 table" while performing the client deletion?

    Or did you delete the required client from T000 table manually after completing the client deletion?

    Usually if you don't perform above steps, the deleted client entry will still be there in scc4 transaction. Please check.

    Thanks & Regards,

    Sairam Nallamothu.

    Add a comment
    10|10000 characters needed characters exceeded