Skip to Content

Cannot open any unx universe (IDT 23140) in Webi Rich Client

Hi,


Imported today the "BI Platform CMS System Database Sample.lcmbiar" from C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\Samples\bionbi.


Trying to create my frst report as administrator with .unx universe in Webi Rich Client, upon selecting the unx I get "Universe xxx does not exist or your security profile does no allow you to access it (IDT 23140). Creating reports from unv universes is fine.


I wanted to change the access level for Full Control but the "Add/remove rights" from Included Rights option is disabled. (There I can see the System > Universe (information design tool) rights).


Questions: is it an upgrade problem that not all rights are included in Full Control? If so, is it reparable?
Questions: How can I othrewise solve the IDT 23140? (When editing a report from the launchpad the query panel does not show any universe either, not even .unv ones)
I also tried to add these rights for the universe folder containing the unx unverse but no luck.


Background: running on SAP BI 4.2 SP6, upgraded from SAP BOXI 3.1 SP7 by copying the setup with Upgrade Management Tool (to another new empty repository). Everything I did is with the admnistrator login.


Thanks

Add a comment
10|10000 characters needed characters exceeded

  • I have fixed your tags. Please select more careful next time.

  • Later another day, I created a new acces right (Full Control with All rights) and ticked "Granted" for all system, application, content, and general rights whenever available. Some of the rights were very appealing.


    I also changed the top-level security for folders, users, universes and connections for administrator to use this new AL. I did the same for applications >BI Launchpad + Desktop Intelligence + Web Intellingence but still no luck.

    I run the Security Query for administrator (folders, universes, connections, applications) but no rights are denied


    The system we built that BO is bundled with, tells what exact right is missing (one at a time but still, it does not let you guess), also not seeing the universe in edit query panel is commented with: "No business layer sent back from the server". Can't BO be more specific!

    Log on backend machine says "Error! repoAccess.getUniverseInfo() : [repo_proxy 36] UniverseFacade::getUniverseInfo - ISInfoObject has not been found". What does it means?

Related questions

3 Answers

  • Posted on Oct 29, 2019 at 02:42 PM

    I believe that you may not have the CMS data driver installed. You don't mention which version of BOBJ you have - you need at least 4.2 SP3. Also, if you upgraded an older system, the CMS data driver is not automatically installed. Instead, you need to do a "change" install to get it. To do this, open "Programs and Features" on the server, find the first/earliest install of BOBJ on the server (not an additional service pack or patch!), right-click on it and select "Uninstall/Change". Select the option that will let you add features. When you get to the screen where you can add items, scroll toward the bottom of the Database list and find the CMS database driver. Select it and continue the update install.

    Note that you will NOT have to re-install any additional service packs or patches after this install completes - the way the installer now works, it updates the install cache in the InstallData folder every time it runs, so all of the programs from the latest installs are there.

    -Dell

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 31, 2019 at 03:08 PM

    Hi,

    Thanks for your answer, Yes I did mention the version. 4.2 SP6.

    We installed the server software on a brain new machine so the driver should be the proper one (4.2 SP6). Looking at features it is already selected.

    Trying to import the biobbi in UAT and see if I get the same problem

    /Thierry

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 01, 2019 at 12:24 PM

    Same issue in our UAT.

    Opening a webi report delivered in the same package from CMC > Folders into thin Webi in a browser and refreshing it works fine, editing it too and I can also see the universe in Edit Query Panel. Trying to create a new report is also fine, the unx is available and selectabke (no IDT error).

    Doing the same in our DEV platform, the Edit Query Panel does not show the unx at all. Creating a new report the unx is available and selectable but not visible in the edit Query Panel.

    Puzzled as I thoug hI gave administrator even more rights in DEV.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.