Skip to Content
0
Oct 29, 2019 at 03:19 AM

s/4 hana application setup error

113 Views Last edit Nov 15, 2019 at 06:50 PM 2 rev

when I setup s/4 hana application at step 3 there is an error

I check the HdbCmdOut.log,the content is as follow:

Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Run SQL command: SELECT USER_NAME FROM USERS WHERE USER_NAME = 'SAPHANADB' Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.sl.lib.utils.cmd.clazz.CreateDatabaseSqlUser | SAPHANADB User already exists. It will be dropped first and then recreated. Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.sl.lib.utils.cmd.clazz.CreateDatabaseSqlUser | ------------------------------------------------------------------------ Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.sl.lib.utils.cmd.clazz.CreateDatabaseSqlUser | Next clazz for BatchExecution is: HDICheck Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.sl.lib.utils.cmd.clazz.CreateDatabaseSqlUser | Execute HdbCmdClazz: class com.sap.hdb.sl.lib.utils.cmd.clazz.HDICheck Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Last user: System, New user: SAPHANADB Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Closing connection: jdbc:sap://ZHANG:30013?databaseName=HDB Connect user: SAPHANADB Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Instance is a multiple-container system. Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Start new connection with connect URL: jdbc:sap://ZHANG:30013?databaseName=HDB connect user: SAPHANADB Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.core.main.cmd.HdbCmdMain | Error during execution of HdbCmdClazz section! Tue Oct 29 08:21:37 CST 2019 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.db.jdbc.exceptions.jdbc40.SQLInvalidAuthorizationSpecException: [10]: authentication failed.

note 2462111 means Incorrect password used,but I did not config password for SAPHANADB,by note 2819272 I can not execute sql:alter system alter configuration ('global.ini', 'SYSTEM') unset ('communication', 'sslEnforce') with reconfigure;

SO How can I correction this error,thank you.

Attachments

?.jpg (32.5 kB)