Skip to Content
0
Oct 23, 2019 at 08:55 AM

SAC - Linked Model only works as a filter

528 Views Last edit Oct 22, 2019 at 02:35 PM 2 rev

Fellow users,

I'm quite new to SAC since my company has only recently switched to Sap4HANA. I am currently working on my first Story. I am combining our data from BW with an Excel-file I have on my local machine. Simplified layout:

So now I link both models to each other, like this:

I can now see the new field "Prod Segm 2" in my Story. I added it as a Page Filter an when I filter on "Broilers", I see the data in my charts change, showing me only the "Broilers". So far, so good. However, when I want to show all the data in a table, I see this (the "Prodh_L4_measure" is the automated measure SAC created when I converted my Excel-file into a Model, since it had no Measures, only Dimensions):

Somehow, on the background somewhere, SAC combines all the data and does not show it on the right line. If I filter on "Broilers", the table changes to this:

So, it does know which data belongs to "Broilers", as it shows the right amount, only it does not give it the name "Broilers" but puts it on "(Null)" instead.

Am I missing a step somewhere? I can't understand what I'm doing wrong here... I already tried switching the models (in the Link Dimensions step) and already tried out all three possible Link Type's in the table (All Primary Data, All Data and Intersecting Data Only), but nothing seems to work...

Any help would be greatly appreciated, thanks in advance!

Attachments

example-1.png (5.9 kB)
table.png (19.6 kB)
table-2.png (15.1 kB)
example-1.png (6.2 kB)