Skip to Content

Objects in Transport Request getting deactivated on Transport

hello,

whenever I am transporting any requests from the development gateway server to the quality gateway server, the objects in the TRs get deactivated. the objects are all active on development but they get deactivated when they reach the quality server.

while it is possible to activate them manually, there are some automated processes that happen on transportation that are not happening and doing those manually isnt feasible.

How can I resolve this issue??

Regards

Siddharth Shaligram

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Oct 22, 2019 at 10:18 AM

    Please check out my following blog

    How to Maintain SAP System Alias Entries in Productive Systems?

    https://blogs.sap.com/2013/05/31/how-to-maintain-sap-system-alias-entries-in-productive-systems/

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 22, 2019 at 05:57 AM

    Which object types are you talking about?

    As described at the end of my blog:

    https://blogs.sap.com/2014/07/07/how-to-transport-fiori-like-applications-using-sap-solution-managers-quality-gate-management/

    The following objects have to be transported between the SAP Gateway server systems:

    Object Transport Type PGMID OBJECT

    Service Repository Object R3TR IWSG

    Model Repository Object R3TR IWOM

    ICF Node Repository Object R3TR SICF

    System Alias Customizing R3TR TABU

    Serivice Registation on the Hub Customizing R3TR TABU

    and the following objects have to be transported between the SAP Gateway backend systems

    Object Transport Type PGMID OBJECT

    Service Builder Project Repository Object R3TR IWPR

    Model Provider Class Repository Object R3TR CLAS

    Model Provider Extension Class Repository Object R3TR CLAS

    Data Provider Class Repository Object R3TR CLAS

    Data Provider Extension Class Repository Object R3TR CLAS

    Model object Repository Object R3TR IWMO

    Service object Repository Object R3TR IWSV

    Add a comment
    10|10000 characters needed characters exceeded

    • I transported an OData service, Fiori application, catalog and group for that application. and all of them had to be activated manually. I activated the ICF node, catalog and group, and application manually. but the system alias cannot be assigned manually as the client doesn't allow for the creation of TRs on quality. so that is why i am looking for a way to fix this issue.

      the system alias use to get assigned automatically and did not need to manually transport in the past. but for some reason that has stopped which is the problem i currently have.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.