Skip to Content

[SAPUI5] manifest.json could not be found in App

Hi. SAPUI5 experts. I am suffering from error when I submit my source to SAP repository.

Error when updating index for UI5 repository ~~ App Index not updated, 'manifest.json' could not be found in App ~~~ Application component of SAPUI5 repository ~~ could not be determined.

when I run SE38- /UI5/APP_INDEX_CALCULATE, it gives the same message.

I didn't meet this kind of error before I reinstall my eclipse to Neon. One of my co-works said it would be on Toolkit version. So I reinstalled old version of UI5 software. but still system returns the same error. Could any expert give advise? Thanks.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Oct 22, 2019 at 06:56 AM

    hi Enju,

    i believe you are not using GIT or any other repository for your source code versioning. You directly extract the code from your Gateway system in eclipse and made changes to it.

    Seems to be issue with the mapping file UI5RepositoryPathMapping.xml in the repository.

    Try to submit the source with just empty structure ( with no files) to repository once so that all files in repository get deleted and the mapping file will be updated accordingly.

    Once that is successful , submit the source with complete structure along with files. it should resolve the issue.

    Thanks,

    Vaibhav

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.