Skip to Content

OData $batch request from WebIDE fails

Hi experts,

I'm having below issue.

OData service has been set up in Gateway server and tested.

A Fiori worklist application has been created in WebIDE using above OData service.

When executing this app, $batch call fails. (It is trying to fetch $count and top 20 records from an EntitySet)

batch.png

I added below entry to manifest.json to prohibit $batch call and this worked.

"settings": { "useBatch": false }

manifest.png

So it seems that the Gateway is not accepting $batch request.

$batch had worked before and today suddennly this issue started to pop up.

Does anyone have idea how to solve this?

batch.png (6.8 kB)
manifest.png (3.5 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Oct 23, 2019 at 02:52 AM

    The issue has been resoleved.

    In tr:SICF for this OData service, I had configured GUI setting as below for testing the service in Gateway client.

    ~CHECK_CSRF_TOKEN = 0

    After this change, the issue started to occur.

    I have removed above parameter and now $batch request is working.

    Add a comment
    10|10000 characters needed characters exceeded