Skip to Content
avatar image
Former Member

Error in JCo Connection creation

Hi All,

When I create a JCo connection on my local J2EE it fails with the error enclosed as below:

com.sap.mw.jco.JCO$Exception: (102) RFC_ERROR_COMMUNICATION: Connect to message server host failed Connect_PM TYPE=B MSHOST=frces4066 GROUP=PUBLIC R3NAME=AM1 MSSERV=sapmsAM1 PCS=1 ERROR partner not reached (host frces4066, service sapmsAM1) TIME Mon Apr 03 18:44:33 2006 RELEASE 640 COMPONENT NI (network interface) VERSION 37 RC -10 MODULE nixxi_r.cpp LINE 8596 DETAIL NiPConnect2 SYSTEM CALL SiPeekPendConn ERRNO 10061 ERRNO TEXT WSAECONNREFUSED: Connection refused COUNTER 1

When I try and ping the JCo the error is as enclosed below:

Failed to ping JCo destination WD_COMMITMENT_MODELDATA_DEST

I have maintained the enteries in hosts file as well as the services file and when I telnet the server on port 36XX where XX is the system number of the system I create the JCo for it connects successfully.

When I test the CIM test for the SLD that connects successfully.

Where and why is the JCo failing after creation?

Can someone throw some light on this error.

Thanks in advance for all your help.

Best regards,

Divya

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Apr 03, 2006 at 01:29 PM

    Hi,

    Please open the services file in the following location c:\WINDOWS\system32\drivers\etc

    Add the entry as the last record

    'sapmsAM1 3600/tcp'

    Test the connection and if it fails, restart the server and test it again, it should work.

    Hope that helps.

    Regards,

    S.Divakar

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 03, 2006 at 02:00 PM

    Divya,

    your connection is "refused". this could be because of:

    - "frces4066" can't be accessed. try to ping the name from your J2EE engine ("ping frces4066" in a command line)

    - sapmsAM1 has a wrong port number in your services file (check your "dev_ms" trace file in ST11. there should be a line like "*** I listen to port sapmsAM1 (36xx) ***" at the beginning)

    kr, achim

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      hmmm, what about your "PUBLIC" logon-group in the backend.

      check with SMLG, if the attribute "Ext. RFC enabled" is set. (I suppose the logon group PUBLIC exists, since it would be another error-message, if not)

  • avatar image
    Former Member
    May 25, 2006 at 03:33 AM

    Hi All,

    Anyone can help? I got the same problem. It seems that the PUBLIC group in NSP ABAP system can't not be accessed.

    Here is my system landscape:

    - I have installed the Java and ABAP in the same host

    - My ABAP system is NW2004sSneakPreviewABAP, Java is SAPNetWeaver04_SP16Preview

    1) I set up SLD successfully (import CIM, run <b>RZ70</b>, the ABAP system shown up in the Technical Landscape in SLD

    2) I created JCO destination with Load Balancing but it failed to ping and to test

    3) I already define the group 'PUBLIC' in tx <b>SMLG</b> but from SAPGUI I can't add the group. I got the error message "<b>Message Sever could not find any group</b>".

    4) The PUBLIC group does not show if I run the program <b>'lgtst'</b>.

    -


    Test lgtst:

    ===========

    c:\usr\sap\NSP\SYS\exe\nuc\NTI386><b>lgtst.exe -H hpxp2 -S sapmsNSP</b>using trcfile: dev_lg

    list of reachable application servers

    -


    <b>[hpxp2_NSP_00] [hpxp2] [10.10.0.10] [sapdp00] [3200] [DIA UPD ENQ BTC SPO ICM ]</b>

    c:\usr\sap\NSP\SYS\exe\nuc\NTI386>lgtst.exe -H hpxp2 -S 3600

    using trcfile: dev_lg

    list of reachable application servers

    -


    [hpxp2_NSP_00] [hpxp2] [10.10.0.10] [sapdp00] [3200] [DIA UPD ENQ BTC SPO ICM ]

    James

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 25, 2006 at 10:23 AM

    Hi Divya,

    If pinging the server is successful from the server machine and entries present in services file as said, then try "SPACE" as the logon group while creating the JCO destination. It happens to be the default and works fine.

    Hope that helps.

    Regards,

    Rajit

    Add comment
    10|10000 characters needed characters exceeded