Skip to Content

Populating Payroll ID on Compensation Info

Greetings,

I'm having an issue populating Payroll ID field using UserID during a hire action.

I used the Employment Information Model as my base object and saved the rule on Comp Info portlet as onSave rule.

I also tried the following:

Comp Info Model

Comp Info

I did not have any lucks.

Any idea why it may be causing an issue?

Thanks.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Nov 07, 2019 at 07:10 PM

    Hi Berna

    use the base object as HireActionModel and try the rule as shown in the screenshot.

    Please assign the rule to "compinfo" object under trigger rules as

    Base Object - "Employee Information Model" and Event Type as "onSave"

    the rule picks up the next employee id which will used when we create/add new employee, the same id will be assigned to payroll id field in compensation info.

    Thanks

    Aja


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.