Skip to Content

User sync issue

Hi,

We are on SAP BusinessObjects BI Platform 4.1 Support Pack 5 Patch 3 (Windows 2012 and Tomcat and we use Windows AD Authentication. Recently we started noticing one issue – New users are not mapped into BO from AD. Our Windows AD plugin scheduler runs for every 20 mins. Existing user’s role updates as expected but new users are not added to the system. There are NO errors in the Event logs, Application logs or Tomcat logs. But when we click on manual update on the Windows AD, it fetches the new user. SAP recommendation is to increase the schedule from 20 mins to 8 hours. We still face the issue.

Any help is appreciated.

Thanks

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Posted on Sep 18, 2019 at 07:26 PM

    here's a quick link on how to lookup external directory details. https://apps.support.sap.com/sap/support/knowledge/preview/en/2546772

    I thought you were on 4.2 missed the 4.1 but the empty group issue is supposed to be for scheduling and updating not just scheduling

    https://apps.support.sap.com/sap/support/knowledge/preview/en/1919273

    -Tim

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 18, 2019 at 06:49 PM

    changing the update time should be set based on the need for getting updated information, it's best to be an hour or more but 8 hours isn't necessary.

    Is the schedule set for the groups and aliases instead of just the groups? That's the 1st common mistake

    There's no reported issues that just affect scheduling and basically if you hit update from groups and aliases it should do the exact same thing as scheduling

    Does event viewer show the updates that the update started and completed during the scheduled update? I believe there are 3 lines in event viewer for each update and one should show how many users it fetched. It can also be checked in CMS tracing https://apps.support.sap.com/sap/support/knowledge/preview/en/2543957

    -Tim

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 18, 2019 at 07:00 PM

    Hi Shridhar,
    It's a known bug in BI 4.1 SP5 & typically occurs after a specific scenario of an empty Windows AD group. Did you have a following situation in your environment?

    1) Windows AD group "ABC" had only two users X & Y.
    2) With Windows AD in CMC, The users were created in CMC & were present in right group
    3) In Windows AD the users X & Y were moved out of group ABC causing the group to be empty.
    4) In CMC the users X & Y were still in the same group.

    If this situation occurs, then the new user addition process stops working.

    Add a comment
    10|10000 characters needed characters exceeded

    • I hope it is working fine already by now after the workaround mentioned in the Tim's note below. Unfortunately I don't see a way to find easy way of identifing the users/AD groups who caused the issue. You might be to trace back the timeline of the events to the date when the issue first surfaced & see what AD groups changed around that time.

      As the Note 1919273 in Tim's reply says, the work around is to remove the empty groups from CMC or apply the next applicable version of the patch.

      Let us know if it fixes the issue.

  • Posted on Oct 03, 2019 at 02:20 PM

    Hi Vaibhav,

    According the KBA, it is fixed in SAP BusinessObjects BI Platform 4.1 Support Pack 5 Patch 3 and we are already on that version.

    It was working fine for so many years. So I do not think that's the cause.

    We have both User Alias and User Group Alias. The problem still persists.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 17, 2019 at 11:42 AM

    Try using the queries in this to spot the empty groups https://apps.support.sap.com/sap/support/knowledge/preview/en/2546772

    you may need to combine them.

    -Tim

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.