Skip to Content
0

SAP HANA 1.0 SPS12 (122.05) - installation of HRTT using xs install leads to crashed droplets

Feb 13, 2017 at 06:52 PM

537

avatar image

Hi everyone,

today I wanted to install the SAP HANA Runtime Tools (it's a precondition for installation of SAP WebIDE for SAP HANA) and did not succeed. Although I used the latest Support Package & Patch (from service.sap.com) and als tried to use the SAP HANA platform installation data unit (9GB archive) always the same error comes up:

"Error starting application: "hrtt-service": some instances have crashed"

I also had a look at the installation log file, but not really more information to be obtained there.

First I thought something about missing authorizations but I am already using the XSA_ADMIN user and also assigned SpaceDeveloper to the corresponding <ORG> and used space SAP.

Within the xscontroller logfile I found this entries:

[2017-02-13 16:11:45:391]-[Controller.Application]-[log]-[XSA_ADMIN]-[client_69ab::startApplication - 175]: Starting 1 instance(s) of application "hrtt-service".

[2017-02-13 16:11:46:909]-[Controller.Application]-[log]-[XSA_ADMIN]-[client_69ab::startApplication - 175]: Starting new instance 'f2ddcc34-1c58-49fb-8a65-112a57931fca' of application "hrtt-service" (port 50015, index 0).

[2017-02-13 16:11:46:909]-[PlatformRouter]-[log]-[XSA_ADMIN]-[client_69ab::startApplication - 175]: Reloading configuration of SAP WebDispatcher.

[2017-02-13 16:11:52:104]-[Controller.Balancer]-[warning]-[controller]-[balancing - 14]: Stopped balancing of application "hrtt-service" (droplet '643ed8a4-b3b5-41e2-a679-4825158b31ce').

[2017-02-13 16:11:53:483]-[Controller.Route]-[log]-[XSA_ADMIN]-[client_a851::deleteRoute - 193]: Removed route with guid '9c845f49-9a5c-4a8e-bf63-3da772510c8a' (host: 'null', port: '51006', orphaned: '0')

Could it be that an incorrect SAP WebDispatcher configuration leads to that issue? It was the last activity before the controller decided to "stop balancing" the hrtt-service.

Thanks for your help.

Cheers

Martin

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Martin Steinberg
Feb 28, 2017 at 12:06 PM
0

Today we received an answer from SAP Support (thank you, SAP Support). Currently there is a bug within HRTT Version 1.0 Patch 5. The node.js runtime causes errors and has to be changed. This is currently in progress by SAP product development and will lead to a new patch 6, soon.

Share
10 |10000 characters needed characters left characters exceeded
Martin Steinberg
Mar 09, 2017 at 08:46 PM
0

Today the corresponding patch was published today on https://service.sap.com/swdc


XSACHRTT02_6-70001571.ZIP

SP02 Patch6 for SAP HANA RUNTIME TOOLS 1.0

Share
10 |10000 characters needed characters left characters exceeded