Skip to Content
0

Data Refresh problem when calling BI Web services (BIWS) with prompts simultaneously

Feb 13, 2017 at 04:49 PM

31

avatar image

Hi,

We have recently noticed the following issue:

- Just create a simple report block with a prompt (e.g: a efashion Universe based report with 2 columns: State & Revenue and and State ? as prompt)

- Publish the report block as a BI Web Service (Including the prompt)

- In a dashboard (old xcelsius) create 3 connections: each of one calling the previous published BIWS with a different prompt answer (e.g: colorado, california, dc). All 3 connections muts have the refresh parameter set to TRUE. All 3 share same user/password info. All 3 are refreshed at startup.

If the value of each connection is displayed in the dashboard I would expect to see the answer of each prompt on the call to the BIWS. But instead of that this is what we are retrieving:

We have done several tests and the pattern seems quite clear: when the BI service which includes the prompt is called multiple time in a short interval of time (<10 seconds) it looks like the calls are using the answer from the previous one instead of its own one.

Browsing on Q&A we have seen similar issue when using QaWs (not BIWS)

Data refresh problem - QaaWS and Tomcat cache https://archive.sap.com/discussions/thread/1260464

Anyway we have tried to apply the workaround provided there but it does not work for us.

Anyone has noticed this issue and knows how to manage it?

Thx

Alfons

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers