Skip to Content
0
Aug 14, 2019 at 12:38 PM

In HANA Studio "Installed Plug-ins" did not show up / No way to get plug-ins in S4/HANA

891 Views

Hello,

i#m new to HANA (S4/HANA) and i#m struggling with some problems.

My colleauges need the LiveCache functionality, therefore i tried to configure nit following Note 2407589.

I checked note 2074843 for the correct version that should be needet for my HANA 2.00.040.00.1553674765 (fa/hana2sp04).

Then i tried to check which LCAPP version is installed and failed. Following http://sapbasisinfo.com/blog/2017/12/04/find-installed-plugins-on-hana-database/ i can see that i have NO "Installed Plug-ins" link in HANA Studio and that also at OS-level the path "/hana/shared/SID/exe/linuxx86_64/plugins" is missing.

Even i have this problems i followed Note 2407589 and did Point 2 (connecting DBA-Cockpit connections LCA, LDA, LEA to LiveCache) but failed at point 3 (granting permissions via SQL) with error:

-------------------------

Could not execute 'GRANT AFL__SYS_AFL_LCAPPS_EXECUTE to SAPHANADB' SAP DBTech JDBC: [332]: invalid user name: SAPHANADB: line 1 col 38 (at pos 37)

---------------------

even SAPHANADB is the owner of HANADB

Can someone help me:

  • get the version of intalled LCAPP
  • do point 3 on Note 2407589

Thank you.