Skip to Content
0
Aug 12, 2019 at 06:47 AM

HANA Express: di-core: fails to start on update to 2.00.040.00.1553674765

279 Views Last edit Aug 11, 2019 at 09:55 AM 4 rev

Hello,

I use a VM version of HANA Express and wanted to do the update from 2.00.036.00.1547699771 to 2.00.040.00.1553674765.

The process runs smooth until nearly the end, then di-core and di-runner fail to get started, here is the output from the end:

[no errors above ...]

cockpit-js-svc: ready 
Waiting for apps: di-core, di-runner, cockpit-flp-content..
   cockpit-flp-content: ready 
Waiting for apps: di-core, di-runner.......................................................................................

Waiting for apps to start has timeout.

I have tried to restart the VM - ans then also di-runner and di-core won't start. Running the update again leads also to the same result.

I attach some log files:

Here the complete log file of the update process (just the part which I posted above is deleted):

hxe-upgrade-2019-08-10-190541.txt

Here is the output of "xs logs --all di-core" at the time, when the update process broke:

all-log-di-core.txt

and the same for di-runner:

all-log-di-runner.txt

I also tried a "xs restart di-core" and dumped just this output, which you can find here:

restart-di-core-log.txt

Can anybody help me here and tell me how to find the problem and get the update installed?

Thanks,

Jochen

//Edit: I skipped through some other with xs-logs and the webide log looks "promising", there I can find a lot of lines like:

#ERROR#/Handler#########ti0egbKsCjokI6nVm4Sk-fJRuvrA-vkV######jz5wf428#PLAIN##GET request to /w5g/client/package.json completed with status 502 - error while forwarding request to https://hxehost:51028/w5g/client/package.json: unsupported certificate purpose (connecting to hxehost:51028)#

Here is the complete log (had to split it because of the file size limit):

all-log-webide1.txt

all-log-webide2.txt

all-log-webide3.txt

Maybe someone knows how I can solve this issue?