Skip to Content
0

SFTP sender channel error., shows directory is empty.

Feb 13, 2017 at 10:03 AM

499

avatar image

Dear Experts,

I'm working on a scenario where I'm using SFTP sender channel.

The channel is polling but it shows that the directory is empty, whereas files are placed in that directory.

These are my channel configuration details:
Filename : [a-z,A-Z,0-9].*\.txt$
Directory: /Inbox

Please find the below screenshots as reference:

Regards,

Vidhya

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

11 Answers

Supriya Parab Feb 13, 2017 at 10:25 AM
0

Hi,

Do you know the exact pattern of file names? You can mention that pattern instead of the generic one you mentioned in your channel. One more thing, in the channel you have configured name as .xml whereas in the message you mentioned .txt files. Check on this point as well.

Regards, Supriya.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Supriya,

We've used .txt as of now. We've made the changes at channel configuration.
Please let me know if you have any other suggestions.

Regards,

Vidhya

0
Supriya Parab Feb 13, 2017 at 11:01 AM
0

Hi,

I suspect it as file name pattern issue only; just try to give specific file name in channel and try to pick that file. If that works, then you may have to consider giving specific file name pattern only.

Regards,
Supriya.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Dear Supriya,

We've tried by changing filename. But still the same error. Please let me know if you have any other suggestions.

Regards,

Vidhya

0
Raghuraman S Feb 13, 2017 at 11:28 AM
0

Can you post what is the name of the file in the directory

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Raghu,

Please find the below screenshot for filenames in the directory.
These are the files I'm trying to pick.

Regards,

Vidhya

files.jpg (29.9 kB)
0
Raghuraman S Feb 13, 2017 at 12:46 PM
0

Try the below pattern and see if it works

Filename :

[a-z,A-Z,0-9].*\.TXT or .*. if you wish to pick all the files.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Raghu,

We tried with this pattern still the same issue.
Please let me know if you have any other suggestions.

Regards,

Vidhya

0

Try doing some dummy changes in the channel or create a new channel and check.

Also ensure cache is up to date.

0
Karthik Bangera Feb 14, 2017 at 08:05 AM
0

Hi Vidhya,

Just to rule out any file permission issues, did you already check if the folder Inbox has read, write and execute access?

Regards,

Karthik

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Karthik,

I've already tried few steps as mentioned above. Please help me to understand where could be the error.

Please find the below screenshot for permissions.

Regards,

Vidhya

0

Hi Vidhya,

The screenshot isn't visible, request you to try re-attaching it.

Regards,

Karthik

0

Regards,

Vidhya

files.jpg (29.9 kB)
0
Evgeniy Kolmakov Feb 14, 2017 at 08:09 PM
0

Hi Vidhya!

Set the exact name of any of your files as file name in adapter's parameters. If adapter still can't see that file - most likely it's permission issue.

Regards, Evgeniy.

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Hi Evgeniy,

Thanks for replying.
Yes, I've tried that step. I had no luck.
Can you please suggest something on permission issue.
I've also shared the permissions screenshot above.

Regards,

Vidhya

0

Just connect to same ftp folder using any ftp client like Mozilla, for example, with user name/password that are used in channel and check if you can see files in the folder.

0

Hi Evgeniy,

We're facing the issue while reading the directory.

The below screenshots are taken from WINSCP application.

This shows that we're able to connect, we're able to authenticate, the issue is when we read the directory.

Regards,

Vidhya

telnet.jpg (40.7 kB)
0

This means that user doesn't have sufficient permissions to view the folder contents. FTP server can respond to this by two ways: raise error or show empty directory. Ask your FTP server provider team for assist.

Regards, Evgeniy.

0
Raghuraman S Feb 15, 2017 at 09:10 AM
0

In the screenshot permissions are not clear.

also check for any locks in nwa.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Raghu,

How can I check the locks in NWA?

Is it for particular user?

Regards,

Vidhya

0

Hello Vidhya,

This note-821267 should help.

Before that did you give * in the S FTP channel. and check

could be authorization issues as well.

0
Ryan Crosby Feb 15, 2017 at 01:26 PM
0

Hi,

From the original screenshot you have given your regular expression shows [a-z,A-Z,0-9].*\.xml which would not work with the files that you have shown in the other posts. If you have updated to the .txt extension and it still does not work then I think you need to look at the user permissions for the files in the /Inbox directory.

Regards,

Ryan Crosby

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Ryan,

Could you please tell me what permissions we should have, because when we check permissions that shows we have read, write and delete enabled.

Regards,

Vidhya

0
avatar image
Former Member Feb 16, 2017 at 08:29 AM
0

try to delete the channel and create again.

Regards

GB

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Gagan,

We've already tried creating new channel, it gives me same error.

Regards,

Vidhya

0
Former Member
Vidhya Nizamkar

then make another reciver channel and try to place file in same folder.

and then use this channel to pick the file.

And also use the same login Id and password by which you are checking the folder

regards

Gb

0
avatar image
Former Member Feb 22, 2017 at 04:32 AM
0

hi Vidhya,

We faced a similar kind of situation and we set the "time out" parameter in the channel and it worked. Hence please enter a value in TimeOut parameter and check.

Thanks

T

Share
10 |10000 characters needed characters left characters exceeded