Skip to Content
0

Office 365 disabled history/autocomplete in SAP GUI 740

Feb 13, 2017 at 07:47 AM

4.4k

avatar image

Dear all,

Has anybody experienced problems with history/autocomplete function in SAP after Office 365 ProPlus installation? This is getting annoying already as it seems that no matter what I do it stays disabled. I am not the only one in the office that has this problem. Is there a workaround to get the function back?

I have SAP Logon 740 and in Options/Local Data/History function is "On".

Thank you,

Octavian

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Best Answer
Burkhard Berger Feb 22, 2017 at 07:56 AM
0

Hi,

some of our clients were facing the same problem after install of Office 365proplus. Our solution:

rename the file SAPHistory<user>.MdB in directory C:\Users\"user"\AppData\Roaming\SAP\SAP GUI\History,

Close all SAPGUI Windows and SAPLogon

start SAPGUI and choose an instance

After these actions we got a new historyfile.

Best Regards

Burkhard

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Feb 16, 2017 at 04:09 PM
6

Hi Octavian,

The following procedure should work, please navigate to the path as follows:

C:\Users\"user"\AppData\Roaming\SAP\SAP GUI

Try to cut the SAPHistory.mdb file to another folder. Done this, restart the SAP GUI and everything should work from now on.

Kind regards,

Pablo

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Pablo,

Had the same problem and your solution worked for me.

Thanks

Jordan

0
Veselina Peykova
Feb 13, 2017 at 11:50 AM
0

I have Office 365 ProPlus installed (Windows 7, 32-bit) and SAPGUI 7.40 Patchlevel 7 and I don't experience such problems.

Check if the user has sufficient privileges to read and write to the local folder, where the history file is kept, what is the expiry time, file size, number of entries etc. In most cases, where users complain about no data in history, it turns out to be a permissions problem. It probably also makes sense to disable security settings for SAP GUI on a test PC and test with the current configuration.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 16, 2017 at 10:09 AM
0

Dear all,

i experience the same Problem after installing Office 365 ProPlus coming from Office 2016 on Windows 10.

I have the newest SAP GUI patch (7400.3.11.1129) including hotfix PL 11 Hotfix 1 (note 1489891).

I checked all settings for history/autocomplete and everything looks fine..

Thanks!

Best regards!

Jens

Share
10 |10000 characters needed characters left characters exceeded
Jude Bradley
Feb 16, 2017 at 01:10 PM
0

Hello Jens/ Octavian

Did you check

2238623 - History: might not work after MS Office 365 or 2013 upgrade: 32-bit version of MS ACE is required!

If yes, and the issue still occurs, refer to

1176026 - History: doesn't work even after MDAC repair (note 931540)

Regards,

Jude

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 16, 2017 at 01:11 PM
0

the history is stored as an MS-Access -mdb file - the Problem is due to the new MS-Access 2016. The solution is to download an Access 2013 Runtime here:

https://www.microsoft.com/de-DE/download/details.aspx?id=39358

I took the X86-Version

regards, Rainer

Share
10 |10000 characters needed characters left characters exceeded