Skip to Content

SM 58 error while posting IDOC

Hi all,

While posting an idoc from my r3 system, it says that IDOC sent to external system.

When I check in we02/we05, it shows the status 03. But, the IDOC does not reach XI and , I am getting an error in SM 58 stating "<b> METADATA EDISDEF FOR PORT <myportno> , IDOCTYPE and CIM do not.. "</b>

I have done all the requsite configuration for posting an IDOC needed on the R3 side and also in XI.

Any info on what this error implies and what should be done will be helpful.

Regards,

Bhavesh

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    Mar 28, 2006 at 10:05 AM

    Hi Bhavesh,

    i suppose, xi couldn't load IDOC meta data to XI. You can control that in TA IDX2. The Reason is may be the connection between <b>XI and R/3</b>. The check does not work fine. Better switch the given user in TA SU01 to dialog user and try a remote login. If that is possible, your connection is working. Later switch the user back to service user. May be, you can find out the reason as well in XI TA SM21.

    Regards,

    Udo

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 28, 2006 at 10:48 AM

    Hi Bahvesh,

    Have you double check the assigned roles to the users? In XI side has to have the role SAP_XI_APPL_SERV_USER. In R/3 must have the role to execute the function modules from group IDXN. We careful!

    In the guide they suggest to use a role called SAP_XI_IS_SERV_USER but it doesn't include the function module IDXN so you have to create a Z role including this one.

    Might be also wrong passwords or users locked.

    hope it helps,

    David R

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 28, 2006 at 09:59 AM

    hi,

    did you load metadata in IDX2 for your idoc?

    Regards,

    michal

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 28, 2006 at 10:01 AM

    Hi Bhavesh,

    Please go thru this thread

    error in sending idoc

    cheers,

    prashanth

    Add comment
    10|10000 characters needed characters exceeded