Skip to Content
0
Former Member
Mar 27, 2006 at 06:54 PM

InfoPackage loading giving IDOC Error: Status 51

480 Views

Hello Experts,

1) I created a DB view (ZZVIEW05) in the SD area on R3

and it extracts data OK in RSA3.

2) I replicated the DataSource in BW, Created InfoSOurce

activated and created an InfoPackage.

3) Scheduling the InfoPackage is failing with an Error:

Transfer(IDocs and TRFC):Errors Occurred

Request IDOc: APplication document not posted

For the Error, I right Clicked and looked at the IDoc status in the Source System (R3 – where we are getting the data from).

The Idoc with Error has a status of 51 and has the following message:

Any suggestions ?

Thanks, BB

***********************

Function module not allowed: ABI_IDOC_DISPATCH

Message no. B1252

Diagnosis

The function module ABI_IDOC_DISPATCH and the

application object type which were determined

are not valid for this IDoc.

Procedure

1. Please check that the process code in the

inbound partner profile is correct.

2. If this is the case, you should check the ALE

inbound methods ALE inbound methods for the

process code and see whether the specified

function module and application object type are

correct.

3. If this is also the case, then the function

module and the application object type are not

permitted for the logical message type, message

variant, message function and basis type that

are contained in the IDoc control record. You

should check whether the correct values have

been assigned to these fields in the control

record. If they do have the correct values,

then the assignment to the function module and

the application object type needs to be

maintained.