Skip to Content

SAP Administration: can't publish config to Data Hub, button disabled, why?

Just recently I've been unable to publish SAP configuration from Hybris to Datahub, because the button to do this is disabled. I'm talking about the button at:

hybris/hmc -> SAP Integration -> SAP Administration -> Data hub tab -> Start Upload

Normally I've always seen this enabled in the past. But now, when running both Hybris and Data hub locally, the button is greyed out, and I can't activate it. So far I haven't found any relevant errors or warnings in the logs. Does anyone have any ideas why this might occur?

Relevant properties in hybris have been set:

datahubadapter.datahuboutbound.date.pattern=yyyy-MM-dd HH:mm:ss.S datahubadapter.datahuboutbound.password=xxxxx datahubadapter.datahuboutbound.url=http://localhost:8080/datahub-webapp/v1 datahubadapter.datahuboutbound.user=admin sapcoreconfiguration.datahuboutbound.enabled=true sapcoreconfiguration.datahuboutbound.feed=SAPCONFIGURATION_FEED

And relevant properties in datahub are also set.

The datahub localhost_access_log doesn't indicate that hybris is hitting datahub with any http request at all - suggesting to me that the problem is on the hybris side.

As a sanity check, datahub does respond just fine when I hit that url myself in the browser, e.g.

http://localhost:8080/datahub-webapp/v1/feed-pool-status/show-status-map

So the config looks correct, and has worked correctly very recently. What could have changed?

Add a comment
10|10000 characters needed characters exceeded

Related questions

0 Answers

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.