Skip to Content

I'm trying to set X-frame-options to ALLOW-FROM uri. No success through HAC and local.properties/recipes

I'm trying to set X-frame-options to ALLOW-FROM uri. No success through HAC and local.properties/recipes.

Is there a way to change it using backoffice or is there anything else I can do it to simply change that parameter?

Obs.:By the way, it all is required to allow Hybris Sales to perform singlesigon in Hybris Commerce.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Oct 22, 2018 at 04:33 PM

    Add the property to your local.properties and restart the server:

     xss.filter.header.X-Frame-Options=ALLOW-FROM https://somewhere.else.com
    
    

    If this doesn't work (and it should, I've changed this property for countless projects) you have some other problem...

    Are you 100% sure the out-of-the-box XSSFilter is the only thing that sets the X-Frame-Options header?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.