Skip to Content

Hybris 6.7:-server.xml configuration issue in Tomcat 8.0

Hello,

I have set up Hybris 6.7 Commerce with Telco extensions included. After performing 'ant clean all', I am unable to start the server because of this problem in /config/tomcat/conf/server.xml

 <Host startStopThreads="0"      name="localhost"
                   appBase="webapps"
                    unpackWARs="false"
                    autoDeploy="false"
                    startStopThreads="${tomcat.startStopThreads}">

The home tag gets a duplicate entry of startStopThreads="0", due to which the server throws an exception. This property exists in platform/project.properties; why does this happen? Can anything be done to prevent it?

Thanks and Regards,

Add a comment
10|10000 characters needed characters exceeded

  • So I was able to find the reason behind this. I use the SAP Hybris Ee plug-in, which has the option to set the StartStopThreads property to config/server.xml file; I disabled the check-box for the same while importing the projects using SAP Hybris plug-in, as well as while synchronizing projects using the plug-in.

Related questions

3 Answers

  • Best Answer
    Posted on Jun 26, 2018 at 03:40 PM

    So I was able to find the reason behind this. I use the SAP Hybris Ee plug-in, which has the option to set the StartStopThreads property to config/server.xml file; I disabled the check-box for the same while importing the projects using SAP Hybris plug-in, as well as while synchronizing projects using the plug-in.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 30, 2018 at 08:38 AM

    Even I'm facing the same issue, every time startStopThreads="0" is getting appended to the server.xml file Host entry.Hope hybris fixes this.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 15, 2018 at 04:33 PM

    Our config/tomcat/conf/server.xml doesn't contain this first startStopThreads attribute. Just remove it completely and your are fine.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.