Skip to Content
0
Former Member
Feb 02, 2018 at 01:06 PM

Error in Backoffice Screen, while creating a new B2B Unit

119 Views

Hi All,

I'm getting No Read access error in Backoffice when i create a New B2B Unit. I had logged in using admin / nimda.

alt text

When i refresh the page, it throws another error. But it gets resolved once we logout & login.

alt text

Getting the below error in the logs

INFO | jvm 1 | main | 2018/01/30 03:35:19.495 | ERROR [DefaultCockpitWidgetEngine] Could not create widget view INFO | jvm 1 | main | 2018/01/30 03:35:19.498 | java.lang.IllegalArgumentException: The given userID is null! INFO | jvm 1 | main | 2018/01/30 03:35:19.498 | at com.google.common.base.Preconditions.checkArgument(Preconditions.java:122) ~[guava-21.0.jar:?] INFO | jvm 1 | main | 2018/01/30 03:35:19.498 | at de.hybris.platform.servicelayer.util.ServicesUtil.validateParameterNotNull(ServicesUtil.java:138) ~[coreserver.jar:?] INFO | jvm 1 | main | 2018/01/30 03:35:19.498 | at de.hybris.platform.servicelayer.user.impl.DefaultUserService.getUserForUID(DefaultUserService.java:91) ~[coreserver.jar:?] INFO | jvm 1 | main | 2018/01/30 03:35:19.498 | at com.hybris.backoffice.cockpitng.core.user.impl.DefaultPlatformAuthorityGroupService.getAllAuthorityGroupsForUser(DefaultPlatformAuthorityGroupService.java:114) ~[classes/:?] INFO | jvm 1 | main | 2018/01/30 03:35:19.498 | at com.hybris.backoffice.widgets.userrolechooser.controller.UserRoleChooserWidgetController.loadAvailableRoles(UserRoleChooserWidgetController.java:83) ~[backoffice-widgets-6.4.0.3-RC1.jar:?] INFO | jvm 1 | main | 2018/01/30 03:35:19.498 | at com.hybris.backoffice.widgets.userrolechooser.controller.UserRoleChooserWidgetController.initialize(UserRoleChooserWidgetController.java:72) ~[backoffice-widgets-6.4.0.3-RC1.jar:?] INFO | jvm 1 | main | 2018/01/30 03:35:19.498 | at com.hybris.cockpitng.util.DefaultWidgetController.doAfterCompose(DefaultWidgetController.java:115) ~[cockpitframework-6.4.0.3-RC1.jar:?] INFO | jvm 1 | main | 2018/01/30 03:35:19.498 | at org.zkoss.zk.ui.impl.UiEngineImpl.doAfterCompose(UiEngineImpl.java:617) ~[zk-8.0.4.2.jar:3.6.4] .................................... ..................................... INFO | jvm 1 | main | 2018/01/30 03:35:19.500 | at org.apache.coyote.ajp.AjpProcessor.process(AjpProcessor.java:190) [tomcat-coyote.jar:7.0.75] INFO | jvm 1 | main | 2018/01/30 03:35:19.500 | at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:628) [tomcat-coyote.jar:7.0.75] INFO | jvm 1 | main | 2018/01/30 03:35:19.501 | at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:318) [tomcat-coyote.jar:7.0.75] INFO | jvm 1 | main | 2018/01/30 03:35:19.501 | at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_92] INFO | jvm 1 | main | 2018/01/30 03:35:19.501 | at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_92] INFO | jvm 1 | main | 2018/01/30 03:35:19.501 | at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) [tomcat-coyote.jar:7.0.75] INFO | jvm 1 | main | 2018/01/30 03:35:19.501 | at java.lang.Thread.run(Thread.java:745) [?:1.8.0_92] INFO | jvm 1 | main | 2018/01/30 03:35:20.502 | WARN [AuthorityGroupSelector] Cannot get authority groups, current user is null. INFO | jvm 1 | main | 2018/01/30 03:35:20.502 | ERROR [BackofficeMainLayoutController] Current user was null.

can someone please help me to resolve this error.