Skip to Content
author's profile photo Former Member
Former Member

Cluster Datahub Configuration

Hi All,

To create cluster datahub I refer below detailslink text Now in datahub_cluster_seed.conf file I added my system IP instead of 127.0.0.1

include "application" include "datahub_cluster_ssl"

node-akka-port = 2551 node-akka-hostname = "100.100.100.100" //My system IP

node-akka-port = ${?datahub.cluster.node.akka-port} //overwrites only if variable is present node-akka-hostname = ${?datahub.cluster.node.hostname} //overwrites only if variable is present

akka { cluster { seed-nodes = null seed-nodes = [
"akka.ssl.tcp://DataHubActorSystem@100.100.100.100:2551" //My system IP

 ]

}

remote { netty.tcp { hostname = ${node-akka-hostname} port = ${node-akka-port} enable-ssl = true }

 enabled-transports = null
 enabled-transports = [akka.remote.netty.ssl]

 netty.ssl = ${akka.remote.netty.tcp}

 netty.ssl.security {
   key-store = ${datahub.cluster.ssl.workingDirectory}/${datahub.cluster.ssl.keystore.filename}
   key-store-password = ${datahub.cluster.ssl.keystore.storepass}
   key-password = ${datahub.cluster.ssl.keystore.keypass}
   trust-store = ${datahub.cluster.ssl.workingDirectory}/${datahub.cluster.ssl.truststore.filename}
   trust-store-password = ${datahub.cluster.ssl.truststore.storepass}
   protocol = ${datahub.cluster.ssl.protocol}
   random-number-generator = ${datahub.cluster.ssl.random-number-generator}
   enabled-algorithms = [${datahub.cluster.ssl.enabled-algorithms}]
 }

} } Now in datahub_cluster_node.conf file I added my system IP instead of 127.0.0.1

include "datahub_cluster_seed"

node-akka-port = 2552 node-akka-hostname = "100.100.100.100"

node-akka-port = ${?datahub.cluster.node.akka-port} //overwrites only if variable is present node-akka-hostname = ${?datahub.cluster.node.hostname} //overwrites only if variable is present

seed-akka-port = 2551 seed-akka-hostname = "100.100.100.100"

seed-akka-port = ${?datahub.cluster.seed.akka-port} //overwrites only if variable is present seed-akka-hostname = ${?datahub.cluster.seed.hostname} //overwrites only if variable is present

akka { cluster { seed-nodes = null seed-nodes = [ "akka.ssl.tcp://DataHubActorSystem@100.100.100.100:2551", "akka.ssl.tcp://DataHubActorSystem@100.100.100.100:2552" ] }

remote { netty.tcp { enable-ssl = true hostname = ${node-akka-hostname} port = ${node-akka-port} } } }

But in tomcat log I found **Cluster node:- 127.0.0.1**
Is their any thing missing or do I need to create custome.conf files for seed and node to override IP address? Regards, Rasika

9489-tomcat.png (84.9 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Sep 07, 2017 at 04:02 PM

    Hi Rasika, The property values from “datahub.cluster.node.hostname” and “datahub.cluster.seed.hostname” under default.properties overwrites the “node-akka-hostname” and "seed-akka-hostname" respectively. Please make sure and let us know that you don’t have any values under those property attributes to reflect 127.0.0.1 (as reported).

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.