Skip to Content

Not all clusters visible in HAC

We are using Hybris 6.1

We have 5 nodes in the cluster. 3 are for storefront and 2 are used for the back office, cockpits etc. We are facing a issue where in cluster nodes [0-4] are displayed randomly and not all of them together. Sometimes it node 0 shows 0,2,4 but not 1,3, sometimes totally different cluster. Also this varies from cluster to cluster. But none of them shows all of them together.

We have verified the mcast udp details cluster configurations and i am running out of ideas.

Any pointers would be helpful.

below are the local.properties values pertaining to cluster we have #Cluster clustermode=true cluster.id=4 cluster.broadcast.methods=jgroups cluster.broadcast.method.jgroups=de.hybris.platform.cluster.jgroups.JGroupsBroadcastMethod cluster.broadcast.method.jgroups.channel.name=hybris-prd-broadcast cluster.broadcast.method.jgroups.configuration=jgroups-udp.xml cluster.nodes.autodiscovery=false cluster.nodes.ping.interval=10000 cluster.nodes.stale.timout=30000

task.processing.enabled = true for the 2 nodes (node id 3,4) which will be used for the back office, cockpits

task.processing.enabled = false for the nodes(node id 0,1,2) for storefront.

Appreciate your help.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Dec 16, 2016 at 07:20 PM
    1. Check to see if any firewall may drop udp or tcp packets between hybris nodes, disable any firewalls between hybris nodes, restart hybris and try again

    2. Check distribution of hybris nodes across hypervisor hosts, any patterns as it relates to nodes not talking to each other?

    3. Use jgroups multicast sender and receiver utilities to test if nodes can talk to each other using those utilities, test both ways

    4. If you have multiple network interfaces make sure you force hybris to bind on a consistent interface on all nodes

    5. Make sure nodes can resolve each other by name consistently

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 19, 2016 at 01:08 PM

    We've experienced issues with JGroups binding to the wrong interface and/or sending to IPv6 addresses.

    Add the following either to your tomcat.generaloptions or tomcat.javaoptions in local.properties Don't forget you need to at least run ant deploy after changing these properties to get them copied across to the runtime settings.

     -Djava.net.preferIPv4Stack=true -Djava.net.preferIPv6Addresses=false
    

    You may also find that binding to a specific interface helps too

     -Djgroups.bind_addr=match-interface:eth0
    

    obviously you need to choose the correct interface for your machine if you've multiple network adapters in it.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.