Skip to Content
author's profile photo Former Member
Former Member

Hello, I got an error while executing impex for category.

I have executed the below Impex.

$contentCatalog=sample-name $staged=catalogVersion(catalog(id[default=$contentCatalog]),version[default='Staged'])[unique=true,default='$contentCatalog:Staged']

INSERT_UPDATE Category;code[unique=true];$staged;name[lang=en];localizedCode[lang=en] ;gender;;Gender;gender

I got the below error


ERROR [ImpExWorker] (0000B1DM) [FlexibleSearch] line 3 at main script: Flexiblesearch error: no default language provided ERROR [ImpExWorker] (0000B1DM) [FlexibleSearch] line 3 at main script: query was 'SELECT {Category:PK} FROM {Category AS Category } WHERE ({Category:catalogVersion} = ?gs.param.1 AND {Category:code} = ?gs.param.2 AND {Category:localizedCode} = ?gs.param.3 )' WARN [ImpExResultProcessWorker] (0000B1DM) [ImpExImportReader] line 3 at main script: dumped unresolved line ValueLine[unresolvable:line 3: cannot create Category with values ItemAttributeMap[ registry: null, type: , data: {code=gender, catalogversion=sample-name /Staged(8796125856345), name={8796093055008->en=Gender}, localizedcode={8796093055008->en=gender}} ] due to [de.hybris.platform.servicelayer.interceptor.impl.UniqueAttributesInterceptor@2a63a5e8]: unexpected validator error: no default language provided,line 3 at main script,null,HeaderDescriptor[line 2 at main script, insert_update, Category, {}, [code, catalogVersion, name, localizedCode] ],{1=ValueEntry('gender'=gender,unresolved=false,ignore=false), 2=ValueEntry(''=sample-name /Staged(8796125856345),unresolved=false,ignore=false), 3=ValueEntry('Gender'=Gender,unresolved=false,ignore=false), 4=ValueEntry('gender'=gender,unresolved=false,ignore=false)}] INFO [hybrisHTTP9] (0000B1E1) [Importer] Finished 2 pass in 0d 00h:00m:00s:038ms - processed: 1, dumped: 1 (last pass: 1)

Can you help me on the same

Add a comment
10|10000 characters needed characters exceeded

  • Former Member

    Hi Harshavardhan, Can you try to insert the category with this impex? # Insert Categories INSERT_UPDATE Category;code[unique=true];allowedPrincipals(uid)[default='customergroup'];$staged ;myCategory;;

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Jul 18, 2016 at 06:45 PM

    Hi ,

    Thanks for your response. But still got the same error with the given Impex query. I have checked the Lagacy mode "checked" manually in hAC as shown in below figure, it's worked fine. alt text


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.