Skip to Content
author's profile photo Former Member
Former Member

How to prepopulate value in create wizard field and make it disabled in backoffice?

Main target is to prepopulate value of an attribute which is a list type.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Jul 28, 2016 at 01:10 PM

    Hi,

    in the wizard you have the following options:

    • initialize the variable via the assign xml tag:

                 <wz:prepare id="itemPrepare">
                       <wz:initialize property="newObject" type="ctx.TYPE_CODE"/>
                       <wz:assign property="initialAnnotationClass" value="newObject.annotation"/>
                   </wz:prepare>
      
    • you can disable the pre-populated fields via propertys' readonly attribute

    • you can alos disable it via Dthe Dynamic Forms. Documentation available here

    Cheers, Wojtek

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.