Skip to Content
0
Former Member
Jun 06, 2016 at 04:48 PM

Mode=append not working when import tools is used

379 Views

I have a csv file named UserGroup.csv where the sample data is given as: testUserGroup;1000000000 TestUserGroup;1000000001

NOTE : The ids are the user ids. We cannot append the user ids for the same group using commas as this is a generated file from a 3rd party.

I have another file importscript.impex with the following:

-----------------------------------------------------------

INSERT_UPDATE UserGroup;uid[unique=true];members(uid)[mode=append] "#% impex.includeExternalDataMedia( ""UserGroup.csv"" , ""UTF-8"", ';', 1 , -1 );" #-----------------------------------------------------------

I have zipped the two files together and tried to upload the zip using the following steps: 1. Traverse to HMC -> System -> Tools -> Import. 2. In the Import file location I have uploaded the zip, changed the locale lang to en and started the process.

But after successful execution of the script, upon checking the user group contains only the last user. But when I have tried to run the impex using hac, it worked perfectly. It seems mode=append is not working if I try to run the impex using HMC import. Appending the Ids side by side using commas also Please suggest where I am going wrong.