Skip to Content
author's profile photo Former Member
Former Member

Solr DefaultFacetSearchStrategy | Query parameter is passed as empty


I'm using Hyrbis b2b powertools accelerator and facing solr query issue when i turn off the legacy mode in solrquery config.

Problem: In LegacyMode, things are working but when i turn off the legacy mode in solrsearchconfig, Solr uses DefaultFacetSearchStrategy in order to generate solr query and get the search results. With this, everytime i search on the page, same results are shown. When i debug the query below query was printed in the logs:


If you look at the above query, "q" parameter is taking value as "*:*" instead of search term.

Does anyone has experienced this behaviour?

Add a comment
10|10000 characters needed characters exceeded

  • Former Member

    Also tried viewing the platform files, as per the converter class which generates the query, below populators are invoked in order to create a query

                 <ref bean="facetSearchQueryFilterQueriesPopulator" />
                 <ref bean="facetSearchQueryGroupingPopulator" />
                 <ref bean="facetSearchQuerySortsPopulator" />
                 <ref bean="facetSearchQueryPagingPopulator" />
                 <ref bean="facetSearchQueryFacetsPopulator" />
                 <ref bean="facetSearchQueryFieldsPopulator" />
                 <ref bean="facetSearchQuerySpellcheckPopulator" />
                 <ref bean="facetSearchQueryParamsPopulator" />
                 <ref bean="facetSearchQueryCatalogVersionsPopulator" />

    First ref in the list belongs to FacetSearchQueryBasicPopulator.class file which somehow is not opening up in decompiler and i believe its responsible for generating "q" parameter.

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on May 03, 2016 at 06:55 PM

    Why do you switch the legacyMode to false in such case - if it works for you? Have you seen the description of the mode difference: If you want to change mode for search in your application then you will need to check the Index type/properties configuration (fts* fields) because new search strategy doesn't use the populators for free text queries.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.