Skip to Content
2
Former Member
Aug 13, 2015 at 03:44 PM

Media files not found on second Hybris cluster node

864 Views

Hi,

We have a setup with two Hybris app server nodes in a cluster. The media share directory is configured as a local directory which is rsynced between the nodes. We have verified that the rsync works fine.

Now, when a request hits the first cluster node everything works fine and images are displayed. If we hit the second cluster node, no images are displayed. The details can be found below:

App1:

local.properties:

 media.replication.dirs=/opt/hybris/data/
 media.read.dir=/opt/hybris/data/
 media.legacy.prettyURL=true

access.log shows that the image file is found (http 200):

 - ip-omitted - - [13/Aug/2015:14:49:52 +0200] GET /medias/sys_master/images/images/h70/hf7/8796130803742.png HTTP/1.1 200 3920
 

The file is present on disk:

 [hybris@ref-app1 tomcat]$ ll /opt/hybris/data/media/sys_master/images/h70/hf7/8796130803742.png 
 -rw-rw-r--. 1  3126 10.7. 11:21 /opt/hybris/data/media/sys_master/images/h70/hf7/8796130803742.png

App2:

local.properties:

 media.replication.dirs=/opt/hybris/data/
 media.read.dir=/opt/hybris/data/
 media.legacy.prettyURL=true

access.log shows that the file is not found (error code 404):

  ip-omitted - - [13/Aug/2015:14:49:24 +0200] GET /medias/sys_master/images/images/h70/hf7/8796130803742.png HTTP/1.1 404 -

However, the file is present on the local disk:

 [hybris@ref-app2 tomcat]$ ll /opt/hybris/data/media/sys_master/images/h70/hf7/8796130803742.png 
 -rw-rw-r--. 1  3126 10.7. 11:21 /opt/hybris/data/media/sys_master/images/h70/hf7/8796130803742.png

Any ideas where to look?