Skip to Content
0
Former Member
Jul 16, 2015 at 11:05 AM

Datahub Publication Status Hanging To IN_PROGRESS

361 Views

Hi Experts,

I setup datahub by using hyrbis 5.5.0, and setup a standalone server for datahub, and configured Mysql as database. I setup and startup hybris platform by adding datahubadapter extension. I also follow the datahub trail step3 https://wiki.hybris.com/pages/viewpage.action?title=hybris+5+Developer+Training+Trails+-+Import%2C+Compose%2C+and+Publish+Data+Using+the+Data+Hub+-+Step+3&spaceKey=R5T

Data Import, Composition and Publication works for me. But after successful post publiation command, the Publication status alway keeps "IN_PROGRESS" if I run GET command "GET - http://localhost:8080/datahub-webapp/v1/pools/GLOBAL/publications " .

The content of local.properties file in my Tomcat classpath as bellow:

 datahub.encryption.key.path=/Users/stuartli/Work/encryption-key.txt
 dataSource.className=com.mysql.jdbc.jdbc2.optional.MysqlDataSource
 dataSource.jdbcUrl=jdbc:mysql://localhost/integration?useConfigs=maxPerformance
 dataSource.username=hybris
 dataSource.password=hybris
  
 datahub.extension.exportURL=http://localhost:9001/datahubadapter
 datahub.extension.userName=admin
 datahub.extension.password=nimda
 
 media.dataSource.className=com.mysql.jdbc.jdbc2.optional.MysqlDataSource
 media.dataSource.jdbcUrl=jdbc:mysql://localhost/integration?useConfigs=maxPerformance
 media.dataSource.username=hybris
 media.dataSource.password=hybris
 
 datahub.server.url=http://localhost:8080/datahub-webapp/v1


Tomcat logs as bellow after excute publication command:

     INFO: 4 * Server in-bound request
     4 > POST http://localhost:8080/datahub-webapp/v1/pools/GLOBAL/publications
     4 > host: localhost:8080
     4 > user-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
     4 > accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
     4 > accept-language: null
     4 > accept-encoding: gzip, deflate
     4 > content-type: application/json; charset=UTF-8
     4 > content-length: 83
     4 > cookie: __utma=111872281.1263407278.1436245162.1437013657.1437030314.8; __utmz=111872281.1436245162.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); __utmc=111872281; JSESSIONID=1453CB23B31B15E8D3C94F6270453811
     4 > connection: keep-alive
     4 > pragma: no-cache
     4 > cache-control: no-cache
     4 > 
 
 INFO: 4 * Server out-bound response
 4 < 200
 4 < Content-Type: application/xml
 4 < 
 <?xml version="1.0" encoding="UTF-8" standalone="yes"?><publicationActionData><actionId>1</actionId><type>PUBLICATION</type><startTime>2015-07-16T19:17:06.704+08:00</startTime><status>IN_PROGRESS</status><poolName>GLOBAL</poolName><targetSystemPublications><publicationId>1</publicationId><startTime>2015-07-16T19:17:06+08:00</startTime><status>IN_PROGRESS</status><targetSystemName>HybrisApparelCoreInstallation</targetSystemName><actionId>1</actionId><poolName>GLOBAL</poolName><numberOfErrors>0</numberOfErrors></targetSystemPublications></publicationActionData>
 
 Jul 16, 2015 7:17:06 PM sun.net.www.protocol.http.HttpURLConnection writeRequests
 FINE: sun.net.www.MessageHeader@107250fb7 pairs: {GET /datahubadapter/oauth/token?client_id=eic&client_secret=secret&grant_type=password&username=admin&password=nimda HTTP/1.1: null}{Cache-Control: no-cache}{Pragma: no-cache}{User-Agent: Java/1.7.0_79}{Host: localhost:9001}{Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2}{Connection: keep-alive}
 Jul 16, 2015 7:17:57 PM org.apache.catalina.session.ManagerBase processExpires
 FINE: Start expire sessions StandardManager at 1437045477958 sessioncount 0

Did I lost any other configuration in hybris platform side or datahub tomcat server side?

Thanks,

Stuart