Skip to Content
author's profile photo Former Member
Former Member

Actual Attribute name is missing from tooltip

I am unable to see the attribute name as mentioned in the items.xml in hmc when I mouse hover over that attribute. I can only see the localized name but on mouse hover over there should be the actual attribute.

Please suggest how to configure this in hmc.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Jul 03, 2015 at 05:51 PM

    I think this will be because you have the setting hmc.developermode=false

    It's defaulted to true in advanced.properties but you have probably changed it your local.properties

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 24, 2015 at 09:07 AM

    Hi Harleen,

    There is nothing special that we need to do to display tooltip in HMC. It is automatically managed by the framework. When we add any new itemtype in items.xml file and do a system update with Update running system and Localize Types options selected, we see the new item / attributes with tool tip shown.

    You may try doing system update again.

    Regards,

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Harleen,

      The attribute's tooltip is displayed from the following 2 jsp's:

      /hmc/web/webroot/attribute/attributeChip.jsp

      /hmc/web/webroot/attribute/localizableAttributeChip.jsp

      You may try debugging these to find out why tooltip is not coming in your case.