Skip to Content
1
Jun 17, 2015 at 04:41 PM

Datahub generates double quotes which lead to issues

101 Views

Hi,

during import of data using the datahub, we face issues due to a generation of double quotes. We are running on data hub 5.5

CanonicalAttribute

     <attribute>
                 <name>productID</name>
                 <values>
                     <value 
                         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
                         xmlns:xs="http://www.w3.org/2001/XMLSchema" xsi:type="xs:string">XXX T2,5
                     </value>
                 </values>
             </attribute>
 ...
 
 
    <attribute>
                 <name>productID</name>
                 <values>
                     <value 
                         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
                         xmlns:xs="http://www.w3.org/2001/XMLSchema" xsi:type="xs:string">YYY T2,5
                     </value>
                 </values>
             </attribute>


Generated Impex (target attribute is a collection)

 INSERT_UPDATE AlternativeProductNumbers;;alternativeProductNumber[unique=true]
 ;480;"XXX T2,5"
 ;485;"YYY T2,5"
 
     
 INSERT_UPDATE Product .... alternativeProductNumbers(alternativeProductNumber) ... 
 ... ; "XXX T2,5", "YYY T2,5" ...;


The Import of ItemType AlternativeProductNumbers works without issues. The import into hybris of ItemType Product fails with error message

... reason:cannot resolve value '"XXX T2,5", "YYY T2,5"' for attribute 'alternativeProductNumbers ...

Thanks for any hints, Robert