Skip to Content
author's profile photo Former Member
Former Member

bundles perspective doesn't show up in admin cockpit

Hi experts!

First of all, as this is my first question in this forum, I'd like to thanks all the already posted questions, answers and opinions, as I already managed to solve and learn a lot of things from them

My problem is this one:

I'm trying to activate the configurable bundling module, and can't manage to activate it fully:

bundle perspective does show up in product cockpit

but:

  • bundles in product detail (product cockpit) doesn't appear,

  • bundle perspective in admin cockpit is not available

I added these 3 extensions in my localextension.xml:

 <extension name="configurablebundlecockpits" />
 <extension name="configurablebundlefacades" />
 <extension name="configurablebundleservices" />

And updated the system.

I'm working on the 5.5.1 version, downloaded from Hybris web site

Is there some role to assign to users?

Where can I verify this perspective is really configured for admin cockpit? (i.e. detect if the update failed in some way)

Does this depends on Hybris licence?

Thank you!

Fred

Add a comment
10|10000 characters needed characters exceeded

Related questions

7 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 11, 2015 at 10:34 AM

    Hi Fred,

    no, it does not depend on the license.

    1. Should the bundle perspective really show up in admin cockpit? I didn't know that it's there, too.

    2. It does not depend on the license

    3. For the product detail, try to clear the customized settings in the cockpit

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 11, 2015 at 05:10 PM

    Hi Konrad, Thank's for your answer, I've been working on it since then, with no positive results

    1. Maybe you're right, although wiki says some perspective should appear there, the "ant all" log shows nothing but product cockpit update.

    2. good to ear that,

    3. I'm working on a recently configured test local system, with no customized settings. I tried anyway, with no results.

    I just wanted to test this extension, having a few days to investigate Hybris things, so this is not really important (no real project requirement for now).

    I'm going to stop investigating this particular subject for now, maybe I'll turn back later if I manage to have more free time.

    cheers Fred

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 06, 2015 at 07:33 PM

    Hello, I am experiencing some sprf of similar problem. My hybris version is 5.5.1.2 I have these extensions in my localextensions.xml.

     <extension name="configurablebundleservices" />
     <extension name="configurablebundlecockpits" />
     <extension name="configurablebundlefacades" />
    
    

    No problem with ant or update. All sites run without a hitch. Bundles perspective is available in product cockpit; template definitions etc all work fine. My problem comes with the catalog syncronization: on this screen there is no icon to trigger sync. As I sync the entire cataloge I find this message in the log file:

     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:18.025 | WARN  [Thread-3236] [DefaultTypedObject] Can not retrieve object. Reason: Item has been removed.
     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:39.431 | INFO  [Thread-3236] (000000MP) [CatalogVersionSyncJob] Starting configureFullVersionSync ...
     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:39.661 | INFO  [Thread-3236] (000000MP) [CatalogVersionSyncJob] Sync  'sync powertoolsProductCatalog:Staged->Online' (pk:8796095087092) configured 2 entries for job '000000MP' (pk:8796121399797) schedule medias: 1
     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:39.661 | INFO  [Thread-3236] (000000MP) [CatalogVersionSyncJob] Finished configureFullVersionSync in 314ms
     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:39.661 | INFO  [Thread-3236] (000000MP) [CatalogVersionSyncJob] Starting synchronization ...
     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:40.064 | INFO  [Thread-3236] (000000MP) [CatalogVersionSyncMaster] 1. pass, 0 (+0) of 2 items processed (0 %),  0,00 items/sec, 2 (+2, deadlocks:0) items dumped.
     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:40.064 | INFO  [Thread-3236] (000000MP) [CatalogVersionSyncMaster] 2. pass, 0 (+2) of 2 items processed (0 %),  45,45 items/sec, 2 (+2, deadlocks:0) items dumped.
     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:40.166 | INFO  [Thread-3236] (000000MP) [CatalogVersionSyncCronJob] comparing last dumps (2/8797704486942 vs 2/8797704585246) - this might take some time...
     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:40.166 | INFO  [Thread-3236] (000000MP) [CatalogVersionSyncCronJob] done comparing last dumps - dumps are equal
     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:40.166 | WARN  [Thread-3236] (000000MP) [CatalogVersionSyncMaster] sync ended with 2 unfinished items - see last sync media for details
     INFO   | jvm 1    | srvmain | 2015/07/06 20:16:40.166 | WARN  [Thread-3236] (000000MP) [CatalogVersionSyncJob] Finished synchronization in 0d 00h:00m:00s:445ms. There were errors during the synchronization!
    
    

    It seems to be, whenever I add a product to a bundle, a lock is imposed on the product entry immediately. That's the reason syncronization fails.

    My DB is MySQL 5.6. innodb_flush_log_at_trx_commit is set to 0. Any ideas?

    ![alt text][1] [1]: /storage/temp/3433-hybrissyncproblem.jpg


    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 11, 2015 at 10:21 PM

    When you ran the update, you probably forgot to select the Project Data Settings for the 3 extensions that you mentioned:

    1. configurablebundlecockpits

    2. configurablebundlefacades

    3. configurablebundleservices - select Yes to import sample data

    I just tried it and it works fine.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 07, 2015 at 07:04 AM

    Hi , I am also facing same issue as bundles perspective doesn't show up in admin cockpit.Could you guide me by saying the process for this issue.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 07, 2016 at 11:59 AM

    I'm experiencing the same problem using V6.0.0.0. The perspective appears in the Product cockpit but not in the Admin Cockpit. The Bundling Section in the Product Attributes doesn't appear either... Is there anybody working on this issue, and/or is there a related JIRA ticket sombody would know of?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 18, 2016 at 10:51 PM

    If you are using B2B Accelerator you may have that problem. B2B accelerator has a "B2BAdmin" perspective in the same location in admincockpit as the "Bundling", perspective you all are talking about. The reason is that bundling (and subscription) functionality was originally implemented for Telco accelerator that was based on B2C accelerator. When you add all related extensions (for bundling and subscription), the compilation does happen, but "AddtoCart" does not happen. There is a planned road map to make bundling available in B2C as well as B2B, at a later date.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.