Skip to Content
author's profile photo Former Member
Former Member

error while trying to send an email

Hi,

While trying to send an email, am getting an error as :

**[DefaultEmailService]Could not send e-mail pk [8796093061184] subject [${ctx.messages.emailSubject} ] cause: Sending the email to the following server failed : smtp.gmail.com:587**

The same error with any smtp configurations I use.

I referred to the "Email WCMS and Process Engine Integration in the hybris Multichannel Accelerator" doc in the wiki to generate the email.

I am not sure what has gone wrong, can I know how can i get it done?

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on Jan 18, 2015 at 05:18 AM

    Hi Sreedevi,

    The smtp configuration for google mail which i am using have been pasted below. You can try with this smtp settings.

    mail.smtp.server=smtp.googlemail.com mail.smtp.port=587 mail.smtp.user= mail.smtp.password= mail.use.tls=true mail.smtp.starttls.enable=true

    I can send emails with this configuration, try these config settings and tell us if you are facing any issue.

    Regards

    Raghavendra.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 18, 2015 at 06:13 AM

    Hi Sreedevi, please check the n/w firewall of the machine where you are trying to generating the email message. apart from that. what raghavendra told is perfectly alright.

    thanks Bikram

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 19, 2015 at 02:58 PM

    Email is getting generated, thanks for the info. :) But when I try to create a new xyzemailContext.java, and make required changes in xml, i get an error saying as:

    ERROR [TaskExecutor-master-130-ProcessTask [8798026400694]] [ActionNode] Error executing de.hybris.platform.commons.renderer.exceptions.RendererException: The context class [com....context.CustomerEmailContext] is not correctly defined.

    I have also mapped xyzemailcontext in my impex. Apart from that, can I know where should i make necessary changes?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.