Skip to Content
author's profile photo Former Member
Former Member

ZK has not been properly initialized.

I get the following error everytime I update the productcockpit.

Effect: The changes I made in the x-items.xml doesn't get reflected in the productcockpit at all. Even after I update the system.

ERROR [hybrisHTTP25] [UISessionImpl] Can not set ID generator. Reason: ZK has not been properly initialized.
ERROR [hybrisHTTP20] [UISessionImpl] Can not set ID generator. Reason: ZK has not been properly initialized.
WARN  [hybrisHTTP25] [UITools] Execution cannot be null. Is ZK available?
WARN  [hybrisHTTP20] [UITools] Execution cannot be null. Is ZK available?

I found that someone is also facing the same problem. But there's no solution provided :(

ZK Framework error

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jul 15, 2014 at 09:51 AM

    Hi, to manually update (or check if the configuration was applied) you may go to hmc and do the following:

    • naviagate to Cockpit->UI Component Configuration
    • search for appropriate configuration in proncipal (for example code statrt with editor and principal is equal to productmanagergroup
    • choose the right entry and check the media assigned (it should be as you declared); if for some reaso it is not you may manually upload it
    • in productcockpit - Menu -> User settings -> Reset personalized settings

    If you will get exceptions related to data model not being appropriately updated plese watch https://jira.hybris.com/browse/HORST-640.

    Cheers, Wojtek

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 14, 2014 at 11:44 AM

    Hi,

    could you provide more details? Which version of the commerce-suite you are using? What changes you are doing? Maybe you are able to provide a step-by-step reproduction path?

    At the first glance it seems that you should logout and log in - for some reason the session might be outdated (invalid). Anyway, as I said, more detailed reproduction path is required to help.

    Cheers, Wojtek

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Wojciech Gruszczyk

      Hi Thanks for your inputs. But isn't there better way to do it.

      Have a look at the summary below. 1. Update : Changes doesn't get reflected in the productcockpit. 2. Initialize: Changes get reflected in the productcockpit. But I lose all the data :(

      It would be great if you can please let me know how to manually upload the configuration?

      Thank you.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.