Skip to Content
author's profile photo Former Member
Former Member

Problem deploying from netweaver developer studio to Portal

Hi,

I am unable to deploy applications from Netweaver studio to SAP Enterprise Portal. I get the "message" please check user id and password while trying to deply, that too with the administrator user id.

Regards,

Harish

Add a comment
10|10000 characters needed characters exceeded

Related questions

9 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Mar 24, 2006 at 12:49 PM

    Hi

    As I remember it also ask you to look in the sap-plugin.log file, check this out, sometimes it says what is wrong.

    I had the problem when I didn't had the java developer role in the portal, and another time when my password was expired(or locked)

    hope it helps

    Peter

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 24, 2006 at 12:24 PM

    Hi,

    We will be using the SDM password for deploying the code.

    Durign the installation the administrator password is set for the SDM as well. if the basis person has changed it then the deployment will fail.

    please get the current SDM password and use the same for deploying the code.

    Regards,

    S.Divakar

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 24, 2006 at 01:05 PM

    Hi Harish,

    have you set your NWDS server configuration?

    In your NWDS---

    Go to Windows->preferences->SAP enterprise portal->Add server configuration->Give alias,Host name of your server->give port number(you can find it under Visual admin->dispatcher->http provider->host)->Give your login name->say ok.->select Yes I want to remember password for deployment->say apply and ok.

    Now right click your project say upload par file.

    It should work now.

    Regards,

    Karthick

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 24, 2006 at 02:18 PM

    Hi Peter,

    I was able to log into the sdm.So sdm account was not locked.

    Is Java Developer Role necessary to be imported?

    Regards,

    Harish

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 24, 2006 at 02:19 PM

    Hi Divakar,

    The sdm has the same password. I am deplying with user id "administrator".

    Regards,

    Harish

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      You can find Remote GUI for SDM at <Drive>:usrsapJ2EJC00SDMprogramRemoteGui.bat

      please try logging in using the password that you currently have. if you are able to successfully login then you should be able to deploy using NWDS.

      Incase the password is locked then you can use the procedure given in thread below to reset the password.

      urgent--how-to-get-the-sdm-password

      Regards,

      S.Divakar

  • author's profile photo Former Member
    Former Member
    Posted on Mar 24, 2006 at 05:08 PM

    Hi ,

    I am able to log into sdm with the same password!

    Is it because I have not imported java developer role, I am not sure.

    Regards,

    Harish

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      you say that you can log into the SDM remotegui.

      We can try this one out..

      1. Change the SDM password in the remotegui, by clicking on the 'key icon' in the menu bar (on the top).

      2. set the password to the one as the Administrator.

      Try deploying the code.

      Regards,

      S.Divakar

  • Posted on Mar 24, 2006 at 11:49 PM

    Hi Harish,

    Are you able to login to Visual Administrator using the same administrator userid & password?

    Since you have said that you can login into SDM using the same password I guess there is no problem in the SDM deployment.

    Did you get any message like :-

    "Fail to connect to server <server name> as adminstrator".

    Are you able to login into the Portal using administrator userid & password.

    I think NWDS is encrypting / reading wrongly your administrator password while trying to deploy on SDM.

    At the last option try re-installing NWDS but not suggested often.

    Regards,

    B.Guru Subramanian

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 25, 2006 at 07:11 AM

    Hi,

    This is the problem faced when I am trying to deploy from any other user id and password. The Portal is installed on a unix box.

    Is there some security configuration that needs to be done.

    Regards,

    Harish

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 25, 2006 at 07:14 AM

    Hi,

    It has the same password.

    Regards,

    Harish

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.