Skip to Content
0
Jul 30, 2019 at 01:30 PM

The file could not be found [8212757] during deploy mtar with hdi disign-time artifacts

132 Views Last edit Jul 30, 2019 at 01:54 PM 2 rev

when I tried to deploy hdi got this error, where hdi-deploy app tell me that file does not exist. BUT IT EXISTS! even in logs before the error, you can see records about adding, expanding and compiling this file. Also, I checked mtar and this file really exists in the archive.

2019-07-26T20:36:50.031+0000 [APP/TASK/deploy/0] OUT    Adding "src/table/REGION.hdbtable" for deploy...
2019-07-26T20:36:50.031+0000 [APP/TASK/deploy/0] OUT    Adding "src/table/REGION.hdbtable" for deploy... ok
2019-07-26T20:36:50.032+0000 [APP/TASK/deploy/0] OUT    Preparing the make transaction... ok
2019-07-26T20:36:50.032+0000 [APP/TASK/deploy/0] OUT    Preparing... ok
2019-07-26T20:36:50.032+0000 [APP/TASK/deploy/0] OUT    Calculating dependencies...
2019-07-26T20:36:50.032+0000 [APP/TASK/deploy/0] OUT     Expanding...
2019-07-26T20:36:50.035+0000 [APP/TASK/deploy/0] OUT      Expanding "src/table/REGION.hdbtable"... ok
2019-07-26T20:36:50.036+0000 [APP/TASK/deploy/0] OUT     Expanding... ok
2019-07-26T20:36:50.036+0000 [APP/TASK/deploy/0] OUT     Precompiling...
2019-07-26T20:36:50.042+0000 [APP/TASK/deploy/0] OUT      Precompiling "src/table/REGION.hdbtable"... ok
2019-07-26T20:36:50.043+0000 [APP/TASK/deploy/0] OUT     Precompiling... ok
2019-07-26T20:36:50.043+0000 [APP/TASK/deploy/0] OUT     Merging...
2019-07-26T20:36:50.043+0000 [APP/TASK/deploy/0] OUT     Merging... ok
2019-07-26T20:36:50.043+0000 [APP/TASK/deploy/0] OUT     Error: The file "src/table/REGION.hdbtable" could not be found [8212757]
2019-07-26T20:36:50.048+0000 [APP/TASK/deploy/0] OUT     Error: Some requested files/folders could not be found [8212764]
2019-07-26T20:36:50.048+0000 [APP/TASK/deploy/0] OUT    Error: Calculating dependencies... failed [8212108]
2019-07-26T20:36:50.048+0000 [APP/TASK/deploy/0] OUT    Make failed (1 errors, 0 warnings): tried to deploy 1 files, undeploy 0 files, redeploy 0 dependent files
2019-07-26T20:36:50.048+0000 [APP/TASK/deploy/0] OUT   Error: Making... failed [8211605]
2019-07-26T20:36:50.048+0000 [APP/TASK/deploy/0] OUT  Error: Starting make in the container "container-name" with 1 files to deploy, 0 files to undeploy... failed [8214168]
2019-07-26T20:36:50.049+0000 [APP/TASK/deploy/0] ERR Deployment to container container-name failed - error: HDI make failed [Deployment ID: none].
2019-07-26T20:36:50.050+0000 [APP/TASK/deploy/0] ERR Error: HDI make failed
2019-07-26T20:36:50.050+0000 [APP/TASK/deploy/0] OUT (4s 609ms)
2019-07-26T20:36:50.140+0000 [APP/TASK/deploy/0] ERR npm ERR! code ELIFECYCLE
2019-07-26T20:36:50.140+0000 [APP/TASK/deploy/0] ERR npm ERR! errno 1
2019-07-26T20:36:50.141+0000 [APP/TASK/deploy/0] ERR npm ERR! deploy@ start: `node node_modules/@sap/hdi-deploy/deploy.js`
2019-07-26T20:36:50.141+0000 [APP/TASK/deploy/0] ERR npm ERR! Exit status 1
2019-07-26T20:36:50.141+0000 [APP/TASK/deploy/0] ERR npm ERR! 
2019-07-26T20:36:50.141+0000 [APP/TASK/deploy/0] ERR npm ERR! Failed at the deploy@ start script.
2019-07-26T20:36:50.141+0000 [APP/TASK/deploy/0] ERR npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
2019-07-26T20:36:50.238+0000 [APP/TASK/deploy/0] ERR npm ERR! A complete log of this run can be found in:
2019-07-26T20:36:50.238+0000 [APP/TASK/deploy/0] ERR npm ERR!     /home/vcap/app/.npm/_logs/2019-07-26T20_36_50_142Z-debug.log 
2019-07-26T20:36:50.267+0000 [APP/TASK/deploy/0] OUT Exit status 1