Skip to Content
0

Personas: Can't see P icon -

Feb 11, 2017 at 12:15 AM

378

avatar image

Hi all,

I can't see the famous P icon in SAP Screen Personas. A little more precisely - it is not visible in SAPGUI and WebGUI. But it is visible for WebDynpros.

During my analysis I got the idea that somehow the flavors are corrupt. I ran the "Check Flavor Data Model" and it reports three times the same error message:

Flavor does not exist (table USFLAS)

Running "Fix Flavor Data Model" does not seem to do anything. "Clear Flavor Cache" reports something like 0 records deleted.

I checked table /personas/usflas and found three strange entries there:

What do you think of that? Could that be the reason why I cannot see the P icon? Can I delete those entries safely?

I'm using Personas 3.0 SP4 on S/4, NW7.51, Kernel 7.49, Health checker tool reports all notes are installed; I have administraor, editor and consumer role

I hope you can guide me to a solution

Regards

Meinrad

10 |10000 characters needed characters left characters exceeded

Update: Another client on same system. No issues with flavor dsata model. Still the same. Webdynpro seems to be good. WebGUI and SAPGUI not.

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Sebastian Steinhauer
Mar 02, 2017 at 02:53 PM
0

Hi Meinrad,

It sounds like you checked all the obvious things. Can you make sure the profile for the roles have been generated, if that is not it, please simply open an incident for component BC-PER and include a user and an http connection so we can take a quick look.

Cheers,
--
Sebastian Steinhauer, SAP Design
SAP Screen Personas
Product Owner

Share
10 |10000 characters needed characters left characters exceeded
Meinrad Funke Mar 03, 2017 at 08:12 AM
0

Hi Stefan,

thanks for your responce. I can access Personas on WebDynpros with URLS like

/sap/bc/webdynpro/sap/apoc_wd_brf_dec_tab_maintain?sap-client=100&sap-language=EN# 

but neither

/sap/bc/personas/?~transaction=su01&sap-client=100&sap-language=EN

nor

/sap/bc/gui/sap/its/webgui?~TRANSACTION=Su01&sap-client=100&sap-language=EN

is working. I.e. I see transaction but not hte P icon. Roles seem to be okay , too. I'll double-check with our admin and create a ticket.

Thanks for your advice

Meinrad

Share
10 |10000 characters needed characters left characters exceeded